28

I have an acer laptop with these GPUs: - GPU0: Intel HD Graphics 4000 (M) (obviously integrated) - GPU1: NVIDIA GeForce GT 710M

I uninstalled all nvidia-drivers because I was experiencing a lot of bugs and I read here and there that they are not supposed to work with Optimus without either bumblebee or nvidia-prime.

As far as I understand, nvidia-prime would allow me to have the NVidia GPU always on. And to choose between that or always off (i.e. always use Intel)

So now I installed nvidia-prime with

sudo apt-get install nvidia-prime

What am I supposed to do now?

I thought nvidia-prime provided a graphical interface which would allow me to choose which graphic card to use, and even to install the needed nvidia drivers.

By typing "nvidia" in the dash, nothing shows up. From a terminal, the only command available starting with "nvidia" is "nvidia-detect" which just prints "none".

So, I installed nvidia-prime, how do I use it?

  • I follow the instruction from HERE and it works flawlessly for 16.04LTS with i7-4720HQ and GT950M. – arphy Oct 26 '17 at 16:11
21

You need to have both Nvidia proprietary drivers and nvidia-prime to get it working. This can be done by running

sudo apt-get install nvidia-346 nvidia-prime

for Ubuntu 14.04 and 15.04.

Then you will have Nvidia X Server Settings in Dash. And there you can find PRIME profiles.

enter image description here

  • 5
    Thanks, I figured it out. Unfortunately, it's completely broken and renders the whole system unusable/unstable. bugs.launchpad.net/ubuntu/+source/xorg/+bug/1485258 – matteo Aug 16 '15 at 0:05
  • 1
    Could you edit your answer to say if it applies to 16.04? It would help me know if I should investigate why my 16.04 screen has none of the X-Server options--only the last three options appear. Granted Intel is selected on my NVIDIA X Server Settings because NVIDIA option boots with black screen and frozen cursor. – WinEunuuchs2Unix Oct 1 '16 at 18:05
  • 2
    It is same in 16.04, except that the driver version is nvidia-361. – Pilot6 Oct 1 '16 at 18:06
  • 2
    You added a PPA. You'd better ask a question, then to post comments not related to the original question. – Pilot6 Oct 1 '16 at 18:14
  • 2
    There is an PPA (webupd8) with a tool called "prime-indicator" that gives you a task bar notification you can use to toggle the GPU. ppa.launchpad.net/nilarimogard/webupd8/ubuntu – dragon788 Jul 12 '17 at 22:50
5

you can also do

sudo prime-select intel 

(or nvidia or query)

Ubuntu 18.04.1 repositories have been updated with a partial backport of work from 18.10 which dramatically improves the Optimus experience. To call it a night and day difference doesn't do it justice.

But when you are in intel-only mode, the nvidia GUI control panel does not launch. This will fixed since it's not a problem in 18.10, but until then, use the command line approach. I suspect the fix won't arrive until 18.04.2

protected by Community Jul 28 '18 at 23:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.