I have tried various tricks I could find to install the global menu on Xfce and LXDE on the latest Oneiric, but nothing worked. Does anyone have an idea on how to do that? Thanks.

Here's what I've tried so far:

  • Please elaborate on the various tricks you tried.
    – aquaherd
    Oct 17, 2011 at 17:56

1 Answer 1


PPA method

  • Add the following ppa ppa:the-warl0ck-1989/xfce-appmenu-plugin

sudo apt-add-repository ppa:the-warl0ck-1989/xfce-appmenu-plugin

  • Install

sudo apt-get update && sudo apt-get install xfce4-appmenu-plugin indicator-appmenu appmenu-gtk appmenu-qt

  • Right-click on an empty part of the top XFCE panel and choose Panel > Add New Items > App Menu plugin

Manual method

  1. Install the missing dependencies. In a terminal : sudo apt-get install indicator-appmenu appmenu-gtk appmenu-qt

  2. Install the app menu : download this deb and open it with the software center

  3. Enable app menu for firefox and thunderbird. In a terminal : sudo apt-get install appmenu-gtk3 firefox-globalmenu thunderbird-globalmenu

  4. Right-click on an empty part of the top XFCE panel and choose Panel > Add New Items > App Menu plugin


  • Just saw it this morning :-) now trying to compile it for 64bit, anyone tried? Oct 19, 2011 at 9:52
  • @JohannPhilippStrathausen did you try sudo dpkg --force-architecture xfce4-appmenu-plugin_0.10-1_i386.deb ?
    – danjjl
    Oct 19, 2011 at 10:24
  • No didn't try that, maybe it would have worked. Instead, I compiled it via ./configure; make; sudo make install, had to install one additional libindicator-dev or something like that because it was complaining about it in the configure phase, log out, log in, then add it to the panel, working nicely :-) Oct 19, 2011 at 11:47
  • Thank you very much! Just wanted to share the link of the source tar ball for compiling: web.archive.org/web/20150907070609/http://gtk-apps.org/content/… Furthermore the script asks for an unresolved dependency which apparently cannot be satisfied, the package name to be installed is actually xfce4-panel-dev
    – user29310
    Oct 20, 2011 at 15:54
  • :( Frak! Doesn't work for me. Says: Plugin "Indicator Appmenu Plugin" unexpectedly left the panel, do you want to restart it?. And offers me Execute (which brings up the same error again) and remove. Im using Ubuntu 11.10 x64. Oct 26, 2011 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.