0

I have 2 fairly new SATA hard drives that I'm moving to a new machine. One was the boot drive, the other had all 'My Stuff' on it. Both drives were installed under Ubuntu 12.04

I need to copy the contents of the 'My Stuff' drive to the other drive.

So new parts (i5, Asus Z97e Mobo, Asus GTX 970 & RAM)

I couldn't remember which was the boot drive, & accidentally installed Ubuntu 14.04 to the 'My Stuff' drive instead of the boot drive. Not a problem, it made a new partition & I could still access everything.

So I removed the 'My Stuff' drive from the machine, leaving just the original boot drive, which I wiped & installed Win10 on.

I then added the 'My Stuff' drive back in, but could not boot from it. Windows could not read it, disk manager showed the partitions but I didn't do anything.

I then ran Ubuntu 14.04 from a flash drive, hoping to access the 'My Stuff' drive & copy the contents over to the (Windows) boot drive. BUT I can't access any of the 'My Stuff' drive; I apparently don't have the necessary permissions. Apparently the owner is the other drive.

I know about backing up data I want to keep, it was backed up, a full copy was on the other drive (which is now wiped), & most of it was also backed up to a 12 year old PATA drive (which I have got working via USB caddy) but it is completely full with no room for some of the data I wanted to keep.

I also tried putting the 'My Stuff' drive into the USB caddy (which can do PATA & SATA) & tried under Win10 (from HDD) & also tried from Ubuntu (from flash drive) but I just cant access the drive. No permission under Ubuntu & Win10 just cant see it.

I eventually want to run dual boot Win10 & Ubuntu 14.04, but I need to copy some of the contents of the 'My Stuff' drive to the other drive first.

1
2

Try to copy your files as root of your Live-Ubuntu-drive

Open a terminal and type

sudo -i 
nautilus

to open the file manager as root. When done, in the terminal type

exit

to drop privileges.

2
  • I dont know how to get root access, I dont know enough about Ubuntu to do that. I havent used any commands yet.
    – Ssscrudddy
    Aug 15 '15 at 13:40
  • So you did everything with the gui? Open a terminal and type sudo nautilus to open the file manager as root Aug 15 '15 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.