2

This is another question about some software called chirp. It is an amateur radio program for programming frequencies into your radio. If I type :

cd /dev

I change directories. From here I type:

ls

And I get this screenshot./dev_#1.png

Then I type clear and plug the device in to the USB port. After this I put this I repeat the command:

ls

And as you can see, I can see /dev/ttyUSB0 now when I couldn't before. So the computer knows that is is there, but it doesn't recognize it when I start up chirp on this particular port. Per the instructions, I

  1. Put the cable into the radio.
  2. Put the cable into the computer.
  3. Turn the radio on.
  4. Start chirp.

Unfortunately I cannot show you the "radio button" it is hidden on the top. But when you point your mouse over the top it will say "radio" and have a drop down menu that says "download to radio" I try to do this and get this screenshot: Chirp

It was recommended that I type these commands for further testing:

dmesg -T

lsusb

These are the screenshots for the first USP port:

chirp1.1

chirp1.2

And here are the screenshots for the second usb port:

chirp2.1

chirp2.2

And finally the last USB port:

chirp3.1

chirp3.2

From another suggestion I am listing this output. After I type this command:

cd /sys/class/tty
ls -l

I get this output, first with no serial device connected:

No_USB

And then with the device connected to each USB port. The information was not showing up in the screenshot, so I copied and pasted instead.

port 1:

lrwxrwxrwx 1 root root 0 Aug 20 04:51 ttyUSB0 -> ../../devices/pci0000:00/0000:00:12.0/usb7/7-1/7-1:1.0/ttyUSB0/tty/ttyUSB0

port 2:

lrwxrwxrwx 1 root root 0 Aug 20 04:53 ttyUSB0 -> ../../devices/pci0000:00/0000:00:10.1/usb3/3-1/3-1:1.0/ttyUSB0/tty/ttyUSB0

and port 3:

lrwxrwxrwx 1 root root 0 Aug 20 04:54 ttyUSB0 -> ../../devices/pci0000:00/0000:00:10.0/usb1/1-2/1-2:1.0/ttyUSB0/tty/ttyUSB0

I did find one last clue from the last answer. After typing this command:

dmesg | grep tty

I discovered that all of them have different numbers connected to them.

USB_1-2

I don't know why, but I couldn't get a screen shot of the other two. However, this is the information that I saw:

8439.280901] usb 3-1: pl2303 converter now attached to ttyUSB0

9103.795822] usb 7-1: pl2303 converter now attached to ttyUSB0

Update: Now I have two working ports and the one that isn't working has moved back to the right hand side of the computer. The number value for this port is USB_7-1. Again, thank you in advance for all of your help.

  • Do steps 1, 2, and 3, then type (and show us) dmesg -T (only the last several lines) and lsusb. Repeat for the other USB port, – waltinator Aug 15 '15 at 4:10
  • Does the device have an external power socket? Can you try using it on a powered USB hub? – ubfan1 Aug 18 '15 at 17:45
  • @ubfan1-no I am getting the same results on a USB hub that I am on the ports. – BJsgoodlife Aug 19 '15 at 1:49
2
+50

Perhaps there are some clues in stackoverflow.

What's your output of ls -l /sys/class/tty with and without your device in the USB port?

Another way to determine what /dev/ttyS* your device is connected to:

sudo apt-get install getserial

sudo setserial -g /dev/ttyS*

If you only have one connected device, it should be possible to parse the output of setserial to determine what port your device is connected to.

(external source)

If neither of these solutions work, I would probably try to filter the dmesg output, e.g. (assuming 'pl2303' is the giveaway string):

dmesg | perl -ne '/pl2303.*(tty\w+)/ && print $1,"\n"'

should print your ttyUSB device string that you may try to connect to instead of /dev/ttyS*.

  • Borlin-I tested minicom (some of the information in your links) but it will not save the configuration file. Do you have any ideas? Your answer is likely the one that I will vote but I still haven't resolved the issue. – BJsgoodlife Aug 21 '15 at 15:00
  • BJ: Sorry, I haven't used minicom since Motorola 68000 what the hottest thing around, so no clue there. But have you solved the USB/tty detection problem? If not, could you list the output of ls -l /sys/class/tty x 2 and sudo setserial -g /dev/ttyS* here? (Perhaps sudo setserial -g /dev/ttyUSB* too, but I'm in deep waters here...) – Niclas Börlin Aug 23 '15 at 10:25
  • No, I have not yet resolved the issue, but I believe the answer lies somewhere in your feedback. Now the working port is back on the right hand side of the computer. But I am running out of time, Sunday is always full. I will vote your answer. – BJsgoodlife Aug 23 '15 at 13:47
  • BJ, in your own time of course. As far as I understand it, part of the device assignment during boot is random, so I am not surprised that your working port changes. My thinking is to figure out how to determine (after boot) what /dev entry correspond to your device. Let me know your progress here and I'll try to help. Good luck! – Niclas Börlin Aug 23 '15 at 15:13
1

nice to meet another ham on here. The adaptor likely shows up as a different serial port for each USB port you plug into. That's what happened to me. You might want to try different /dev/ttyS# values and see what works.

Good luck

  • @Daniel-thank you for your answer. Although not extremely new to Linux I am unsure of how to do this. Could you please elaborate? – BJsgoodlife Aug 19 '15 at 1:06
  • I tried the above commands for each USB port they are all /dev/ttyUSB0. Still, if you know how to change them it may fix the problem. – BJsgoodlife Aug 19 '15 at 9:59
  • Does the working port seem to be the one that it is plugged into the first time after bootup? – Daniel Aug 19 '15 at 14:31
  • @Daniel-negative, I tried the experiment and it didn't work on one port. Now I have two working ports, the ones on the left hand side of the computer. – BJsgoodlife Aug 19 '15 at 15:21
  • 1
    And do all these ports work with other devices? – Daniel Aug 20 '15 at 2:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.