2

tl;dr Shared files are accessible, but server isn't visible in Windows listing.

I've got printers and some directories shared via Samba, but they do not appear in the listing when a Windows user opens their "Network". They can type "\computername\" and hit enter to see the shared printers and directories, but I'd like to make it easy to see the server listed along with other icons in their Network panel.

This used to work (ubuntu 13-something, I think), but recently (ubuntu 15.04) it doesn't. So something must have changed with the default configuration. It's probably a simple setting in smb.conf, I just don't know where to look. Any hints?

2

I have been using OpenSuse Leap 42.2 and as windows updates is breaks my samba network. This configuration in the [Global] section of samba config has worked until billy's recent updates and stopped working on my Windows 7 and 10 machines. My global section of samba config was:

[global] 
    workgroup = WORKGROUP
    netbios name = LINUXSERVER
    lanman auth = no
    ntlm auth = yes
    client lanman auth = no

I then added the 3 lines found on this site so global now reads:

[global]
    workgroup = WORKGROUP
    netbios name = LINUXSERVER
    lanman auth = no
    ntlm auth = yes
    client lanman auth = no
    wins support = yes
    local master = yes
    preferred master = yes

Now my samba shares show up in Windows 7/10. I know this is a Ubuntu forum but I am always willing to try to help fellow Linux users.

1

add lines in smb.conf

wins support = yes
local master = yes
preferred master = yes
  • For some reason, none of this works for me with Win 10. I always have to manually add the path to the share, or use \\myhostname.local\ – Fiddy Bux Dec 24 '18 at 22:41
1

I want to add this here, in case someone else comes looking. The issue with network discovery is the old way was tied to SMB1. The new way WS-Discovery, does not yet appear to be implemented in SAMBA. Windows does not yet support Zerconf so AVAHI does not work for Windows.

Falling back to SMB1 while disabling SMB2/3 is not the answer.

Someone named stilez wrote an article describing the situation here: https://www.ixsystems.com/community/resources/how-to-kill-off-smb1-netbios-wins-and-still-have-windows-network-neighbourhood-better-than-ever.106/

And the article provides a link to a python script wsdd.py(https://github.com/christgau/wsdd/blob/master/src/wsdd.py), which provides the missing functionality. Running the script caused my SAMBA AD servers to instantly appear on Win 10 boxen.

0

I've been hammering away at this problem for a few weeks, on and off, and it is only now that I have found the last piece of the puzzle for Windows 10 to see Samba shares in Network (places).

It's all described fully at this link:

How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server

Essentially, you need to enable SMBv1 / CIFS sharing support in Windows 10:

Turn Windows Features on or off

Just hit START in Windows and search for 'Turn Windows features on or off' and it'll take you there.

After I did this, all my problems vanished. Tada!

I don't know if it has reduced the security of my network (probably has!), but if it has it doesn't matter to me too much as it's all on LAN anyway.

Hope this helps some other people out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.