tl;dr Shared files are accessible, but server isn't visible in Windows listing.

I've got printers and some directories shared via Samba, but they do not appear in the listing when a Windows user opens their "Network". They can type "\computername\" and hit enter to see the shared printers and directories, but I'd like to make it easy to see the server listed along with other icons in their Network panel.

This used to work (ubuntu 13-something, I think), but recently (ubuntu 15.04) it doesn't. So something must have changed with the default configuration. It's probably a simple setting in smb.conf, I just don't know where to look. Any hints?

5 Answers 5


I want to add this here, in case someone else comes looking. The issue with network discovery is the old way was tied to SMB1. The new way WS-Discovery, does not yet appear to be implemented in SAMBA. Windows does not yet support Zerconf so AVAHI does not work for Windows.

Falling back to SMB1 while disabling SMB2/3 is not the answer.

Someone named stilez wrote an article describing the situation here: https://www.ixsystems.com/community/resources/how-to-kill-off-smb1-netbios-wins-and-still-have-windows-network-neighbourhood-better-than-ever.106/

And the article provides a link to a python script wsdd.py(https://github.com/christgau/wsdd/blob/master/src/wsdd.py), which provides the missing functionality. Running the script caused my SAMBA AD servers to instantly appear on Win 10 boxen.

  • 2
    Thank you for this answer. It put an end to a day of reading random answers, all written at least a couple of years ago for Windows. May 29, 2020 at 18:13
  • Note that if you have nmbd running it may override wsddy.py. I was running nmbd in Docker container and it announced the container's IP address instead of hosts IP address. Turning off nmbd and flushing NetBios cache (nbtstat -RR, nbtstat -c) on Windows hasn't helped, even though Network Neighborhood showed my server, I wasn't able to access it. I capitulated and now I'm running wsdd.py for faster NN discovery and nmbd in hosts mode to announce the proper name mapping. Note that I haven't played with disabling SMB1 and so, so this may affect it.
    – matt
    Jan 13, 2021 at 11:40
  • Is this still the current situation? or is there any better solution? for some reason even with this script Windows still cannot discover my share :( Nov 1, 2021 at 14:54
  • @MohammedNoureldin, yes. There is no better solution that I've found. It looks like steffen has made some fixes to the script, and I've not tried the new one. However, if it's not working for you... here's a few things to check 1) you're invoking the script with the correct arguments. 2) firewall is not blocking 3) Windows Network Discovery is enabled for the local network. (That last one can be kind of tricky because... well Windows. If you look at the look at the repository the script is in (github.com/christgau/wsdd) you'll see that Steffen has provided an excellent readme.
    – Crazy Yog
    Nov 3, 2021 at 5:13
  • Also in the intervening years, I see that no less than a dozen other people have published articles on this. The all appear to reference the same python script.
    – Crazy Yog
    Nov 3, 2021 at 5:17

I've been hammering away at this problem for a few weeks, on and off, and it is only now that I have found the last piece of the puzzle for Windows 10 to see Samba shares in Network (places).

It's all described fully at this link:

How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server

Essentially, you need to enable SMBv1 / CIFS sharing support in Windows 10:

Turn Windows Features on or off

Just hit START in Windows and search for 'Turn Windows features on or off' and it'll take you there.

After I did this, all my problems vanished. Tada!

I don't know if it has reduced the security of my network (probably has!), but if it has it doesn't matter to me too much as it's all on LAN anyway.

Hope this helps some other people out.

  • 4
    My feature menu looked a little different (I'm running Windows 10 Pro), where SMB 1.0 had three sub-componients. I found that all that was needed was the SMB1 client sub-component.
    – G-Wiz
    Aug 14, 2019 at 20:21
  • 8
    For everyone who could read this: This answer seems to work, but, this is far from the best solution. Read the answer of Crazy Yog above, in this same page. Remove SMB 1.0 forever, dont ever think of using SMB 1.0 again.
    – mguima
    Apr 13, 2020 at 16:19
  • does this work also with win10 1909?
    – Pol Hallen
    Apr 24, 2020 at 15:57
  • It worked on my 1909 - very easy solution to a long suffered problem many thanks Apr 26, 2020 at 10:35
  • This allows the use of SMB 1.0 server and shares that way, but does not allow discovery per OP question and is generally a bad idea as mentioned. The best way around this whole struggle IMO is to simply make the share a mapped drive. Works fine that way. Keep SMB 1.0 support off. Users find it easily and this was part of original question w/o having to deal with discoveries showing up or not.
    – B. Shea
    Oct 11, 2023 at 15:32

The problem is that NetBios discovery is now disabled by default in Windows for security reasons, and Samba never implemented support for Web Services for Windows (WSD), which is the "modern" way, AFAICT, for things to be visible in Windows Network.


Also see: https://github.com/christgau/wsdd for a possible solution.

  • Would it show up with a WINS server on the network?
    – paradroid
    Nov 7, 2020 at 16:04
  • wsdd works, runs as user 'nobody' and depends just on Python3. For me this worked. Nov 29, 2020 at 16:51

I have been using OpenSuse Leap 42.2 and as windows updates is breaks my samba network. This configuration in the [Global] section of samba config has worked until billy's recent updates and stopped working on my Windows 7 and 10 machines. My global section of samba config was:

    workgroup = WORKGROUP
    netbios name = LINUXSERVER
    lanman auth = no
    ntlm auth = yes
    client lanman auth = no

I then added the 3 lines found on this site so global now reads:

    workgroup = WORKGROUP
    netbios name = LINUXSERVER
    lanman auth = no
    ntlm auth = yes
    client lanman auth = no
    wins support = yes
    local master = yes
    preferred master = yes

Now my samba shares show up in Windows 7/10. I know this is a Ubuntu forum but I am always willing to try to help fellow Linux users.

  • 1
    Thak's a lot in my case only have to replace wins support = true -> wins support = yes
    – rpaillao
    Dec 7, 2021 at 15:40

add lines in smb.conf

wins support = yes
local master = yes
preferred master = yes
  • For some reason, none of this works for me with Win 10. I always have to manually add the path to the share, or use \\myhostname.local\
    – Fiddy Bux
    Dec 24, 2018 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .