I tried installing Steam today on my laptop, and to no surprise it's broken and needs tweaking just like every single time I have ever installed Steam on Linux.

In my process of trying to fix the missing dependencies, I managed to completely and utterly break my apt-get functionality it appears.

Here's what is going on.

sudo apt-get install cowsay

which pops out the lovely and rather completely useless message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
cowsay is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libllvm3.6:i386 : Depends: zlib1g:i386 (>= 1:1.2.0) but it is not going to 
be installed
 libpciaccess0:i386 : Depends: zlib1g:i386 (>= 1: but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

So I do the next logical step, the console is telling me to run:

    sudo apt-get -f install

Alright, well try that. Nope, I'm just going to give you the illusion that I'm working and make you mad:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:

The following NEW packages will be installed:

0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
6 not fully installed or removed.

Need to get 0 B/52.9 kB of archives.

After this operation, 182 kB of additional disk space will be used.

Do you want to continue? [Y/n] y

(Reading database ... 386548 files and directories currently installed.)
Preparing to unpack .../zlib1g_1%3a1.2.8.dfsg-2ubuntu1_i386.deb ...
Unpacking zlib1g:i386 (1:1.2.8.dfsg-2ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/zlib1g_1%3a1.2.8.dfsg-2ubuntu1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/zlib1g/changelog.Debian.gz', which is different from other instances of package zlib1g:i386

Errors were encountered while processing:

E: Sub-process /usr/bin/dpkg returned an error code (1)

At this point, I feel like I've tried everything. I followed a pretty lengthy guide on try reconfiguring my dpkg, using apt-get clean, and so on. Rebooting has done nothing for me.

I'm completely lost. I'd just reinstall Linux but I don't want to backup all my work just because Steam broke my freaking apt-get.


I just fixed it. What I had to do was outlined in this post: Broken dependencies due to libjackd

So I went to /usr/share/doc and then took zlib1g and zlib1g-dev and renamed both with a .old on the back. This allowed me to do my

apt-get -f install

and things seem to be happy now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.