1

I have tried to install the driver for K80 under Ubuntu for 1 week and I can't install successfully even though I have tried every method from NVIDIA forum/Google.

When I use lspci, the following shows up:
04:00.0 3D controller: NVIDIA Corporation Device 102d (rev a1)
05:00.0 3D controller: NVIDIA Corporation Device 102d (rev a1)

1.The motherboard I use is ASRock Fatal1ty Z97X Killer, which supports PCI-e 3.0 x 16. Would that be a problem? http://www.asrock.com/mb/Intel/Fatal1ty%20Z97X%20Killer/

2.Every time when I want to install the driver for Tesla K80, the following information shows up:

a)the distribution-provided pre-install script failed

b)ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

I have tried installed different version of Ubuntu(12.04/14.04), it still didn't work.

Can someone please explain what the problem is and how can I fix it so I can finally install the drivers?

Thanks,
Jiawen

0

Based on your information

a)the distribution-provided pre-install script failed

i assume you tried to install the driver from a *.run file downloaded at nvidia.com. Did you tried to install drivers from the ppa?

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update && sudo apt-get install nvidia-352

Where nvidia-352 is the long branch driver including support for Tesla and Quadro systems.

If you, for some reasons need to install the drivers from nvidia's page you should make sure you had blacklisted nouveau drivers first:

sudo vim /etc/modprobe.d/blacklist.conf

Add the following lines:

blacklist amd76x_edac 
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

If you had nvidia installed from the ppa recently purge it:

sudo apt-get remove --purge nvidia*
sudo reboot

Once back at your desktop try to install the nvidia drivers again:

Hit Ctrl+Alt+F1 to reach the text mode and login

sudo service lightdm stop
sudo /path/to/nvidia*.*.run

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.