8

A couple of days before, everything is working perfectly good. But After last Ubuntu update -also flash player has updated- (I just think that was occurred after update but maybe not) I can not watch 1080p, 480p and 240 videos in youtube. Actually there is no option just 360p and 720p. I tried to reinstall both Firefox and flash player but nothing change. I thing this problem just related with youtube. Because I can watch 1080p videos from vimeo.com and other websites. Please help me.

A picture from https://www.youtube.com/html5

9

HTML5 is usually better than Flash (particularly security wise), just Youtube's implementation uses Media Source Extensions, which is available in Firefox but disabled by default currently (EDIT: in recent Firefox this should no longer be a issue (since version 44) - IF you have the appropiate codecs installed on your system):

To fix it, basically go to about:config and:

  • ignore the warranty dragons
  • set the media.mediasource.enabled & media.mediasource.webm.enabled entries to true

The YouTube HTML5 player enabling page should look at minimum like this:

working html5 player enabled screenshots
The more blue things the merrier

Then sit back and enjoy 1080p playback (if it doesn't need to buffer for half a hour due to broadband bandwidth like mine does :)


If you need to enable MSE & H264, you should be able to do so using the method suggested here in about:config:

  • Create a new boolean key called media.mediasource.ignore_codecs and set it to 'True' - it may now work so check https://www.youtube.com/html5
  • If it does not work yet, do the following:
    • Set media.mediasource.mp4.enabled to 'True'
    • Set to 'True' all the things begining with media.fragmented-mp4 - except for media.fragmented-mp4.use-blank-decoder which needs to be set to 'False':

All should then work (does for me with Firefox Beta AND ffmpeg available... for ffmpeg on 14.* releases try this question):


EDIT: In Firefox 43 at least, doing the above may break the HTML5 player. There seems to be other issues (atleast with Firefox's useragent), but anyway if it breaks try setting media.fragmented-mp4.gmp.enabled to false (source)

EDIT: again in Firefox 44 (with the default FF useragent) some issues may occur, though for me it shows a error about HTML5 videos when actually becuase videos have been blocked for other reasons (e.g. copyright). I am now forcing HTML5 with this addon Another edit: now doesn't seem necessary on fresh profiles, possibly due to https://www.mozilla.org/en-US/firefox/44.0/releasenotes/#new

0
2

the problem is with the YouTube HTML5 player, I had the same problem and fixed at by installing flash plug-in. then go to this link and choose to disable the html5 player if it's still the default.

Afterwards, it should look like this:

enter image description here

10
  • 2
    HTML5 is usually better, just youtube's implementation (using Media Source Extensions, currently unsupported in FF)... :/ Anyway there is a fix suggested here and another here.
    – Wilf
    Aug 14 '15 at 20:38
  • 1
    yourube html5 player still has some problems @wilf Aug 14 '15 at 20:45
  • @Wilf For me, I get this problem only on Ubuntu 14.04 and FF40, but Windows 7 with FF40 is fine, and Media Source Extensions are active.
    – user3169
    Aug 16 '15 at 4:27
  • MSE works on my Fedora testing build of Firefox 40 (my current ubuntu machines are mainly servers, can't test :), it will show as enabled (bottom left) box here if it is. Enabling media.mediasource.enabled and media.mediasource.webm.enabled seem enough.
    – Wilf
    Aug 16 '15 at 9:29
  • @RonnieDroid thank you for your reply. But I can't find a option to disable html5 player.
    – al0s
    Aug 16 '15 at 10:32
1

It can also be caused by the lack of H.264 codec support on Firefox.

Installing the FFmpeg plugin for GStreamer solved this problem for me:

sudo add-apt-repository ppa:mc3man/gstffmpeg-keep
sudo apt-get update
sudo apt-get install gstreamer0.10-ffmpeg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.