New to ubuntu, just need some help conecting wirelessly.


Bus 008 Device 003: ID 2357:0101
  • Is it a USB adapter?
    – Pilot6
    Aug 14, 2015 at 16:29
  • yes, it is usb 3.0
    – koko
    Aug 14, 2015 at 16:35
  • Please edit your question and add output of lsusb terminal command when the adapter is inserted.
    – Pilot6
    Aug 14, 2015 at 16:36
  • lsusb returns:Bus 008 Device 003: ID 2357:0101
    – koko
    Aug 14, 2015 at 16:50
  • And nothing else?
    – Pilot6
    Aug 14, 2015 at 16:52

4 Answers 4


this worked for me:

sudo apt purge rtl8812au-dkms
sudo apt install git
git clone https://github.com/gnab/rtl8812au.git
sudo cp -r rtl8812au  /usr/src/rtl8812au-4.2.2
sudo dkms add -m rtl8812au -v 4.2.2
sudo dkms build -m rtl8812au -v 4.2.2
sudo dkms install -m rtl8812au -v 4.2.2
  • I'm moving from centos to ubuntu on my desktop because wireless just doesn't work right under centos it seems. (Among other reasons). I want a simple dongle to allow connection to a camera to sync pictures. Ethernet is fine otherwise. Thanks for this. It worked the first time.
    – poleguy
    Mar 27, 2021 at 22:48
  • I tried the above steps but I still cannot get the tplink USB net-device to work. I also tried a restart but didn't work either. I can see it listed in lsusb but not in sudo lshw -C network
    – Kasparov92
    Nov 2, 2023 at 15:49

You can install the driver this way. Connect to Internet some other way and run in terminal

sudo apt-get install git dkms
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
sed -i 's/\#MODULE_VERSION\#/0.1/' rtl8812AU_8821AU_linux/dkms.conf
sudo dkms add ./rtl8812AU_8821AU_linux
sudo dkms install -m 8812au -v 0.1

Then insert your dongle.


First of all, Pilot6, thank you very much for providing this.

I ran into some challenges while installing the repository. If you experience similar issues, please feel free try the following solution that worked for me (note, this has enabled to install the drivers and I have not tested the functionality yet):

cd /usr/src
sudo cp -r rtl8812au-#MODULE_VERSION# 8812au-1.0
sudo dkms install -m 8812au -v 1.0
  • 1
    This is not a full answer. Now it looks like a comment. Can you reprpduce the full steps you did? And what is wrong with my commands? They are doing actually the same.
    – Pilot6
    Feb 19, 2017 at 20:39
  • Oh, I see. They changed the version.
    – Pilot6
    Feb 19, 2017 at 20:41
  • I fixed it in my answer by another way. Yours is good too.
    – Pilot6
    Feb 19, 2017 at 20:48

If the other solutions have been tested and do not seem to work. Try the following (update your network interfaces):

sudo nano /etc/network/interfaces

Remove the standard configurations. Check using dmesg which interface is being used (eth0, eth1, etc.) and add the settings for this interface;

#auto eth0
#iface eth0 dhcp inet
auto eth1
iface eth1 dhcp inet

My issue had to do with the TP Link UE300 usb to ethernet 3.0 adapter which was recognized by ubuntu linux but it did not function. After installing the updates as suggested by @Pilot6 and updating the network interfaces, the adapter started functioning.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .