I just installed Ubuntu 14.04.3 LTS after installing windows 10 in my new VN7-571G and the wireless is not working. It never had: even during the installation it was not recognized.

I run a script to gather the data , which is here.

lspci -knn | grep Net -A2 output

03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 20)
        Subsystem: Lite-On Communications Inc Device [11ad:0804]

The OS behaves like it has no wifi card. I do not see wifi settings in network settings

I'm not a linux power user, so I do not know what to do to solve the issue. What should I do to make it work?

  • I believe his device is covered in ath10k_pci. – chili555 Aug 14 '15 at 15:31
  • There is only 003c. – Pilot6 Aug 14 '15 at 22:11
  • Just one thing. The upload speed through the wireless card is much smaller (50 mbps) than the upload speed through the ethernet card (220 mbps)... – user454890 Sep 26 '15 at 13:53
up vote 9 down vote accepted

This device is supported in Ubuntu 15.10 with the latest updates.

  • You can get it work in Ubuntu 14.04 by installing kernel 4.2 and the updated firmware. Run in terminal:

    sudo apt-get install linux-generic-lts-wily
    wget https://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.157_all.deb
    sudo dpkg -i linux-firmware_1.157_all.deb
    
  • In Ubuntu 15.10 and later you only need to install the firmware:

    sudo apt-get install linux-firmware
    

In both cases, reboot afterwards.

  • Replying to you using the wifi connection now. Great work. Noticed the touchpad scroll is not working now. Can it be related? – Makers_F Aug 14 '15 at 16:04
  • That was the solution I needed to make backports into dkms deb files, you have to copy the backports after running make deconfig-wifi or whatever individual module you want – Jeremy31 Oct 3 '15 at 22:13
  • Many, many thanks for solving problem with my lenovo e31-70 laptop in 3 mins :) – Łukasz Frankowski Oct 14 '15 at 20:21
  • @Pilot6 They released the fixed firmware. Could you reply to askubuntu.com/questions/697448/… ? – Makers_F Nov 13 '15 at 3:28
  • 1
    @Makers_F Sure packages.ubuntu.com/… – Pilot6 Feb 21 '16 at 15:23

protected by Pilot6 Oct 16 '15 at 14:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.