1

Hardware:
Acer Aspire ACX-603-UR10
8 GB RAM
Blue WD010EZEX 1 TB HDD
-- or --
Green WD30EXRX 3 TB HDD
-- or --
Samsung HM251JI 250 GB HDD

Seagate ST3160815AS 160 BG HDD (Windows 8.1/now upgraded to Windows 10)

Only one drive is ever plugged in at any given time except when I am cloning from one to the other. I did previously have both the 12.04 (Samsung) and 8.1 (then on the 1TB) drives plugged in together for a dual-boot to windows/ubuntu. However, I wasn't using windows, so I cloned the Samsung to the 1TB drive to upgrade to 14.04 which was eventually cloned to the 3TB drive for a backup.

Samsung was original HDD with 12.04 LTS and partitioned as:
sda1 fat32 /boot/efi 380 MiB 4.11 MiB used
sda2 ext4 / 24 GiB 12.48 GiB used
sda3 linux swap 8 GiB
sda4 ext4 /home 200 GiB (remainder of Samsung HDD)

Background:
The Samsung drive was operating normally with swapon running 12.04 when I decided to upgrade to 14.04. I ran Clonezilla disk-to-disk to copy the Samsung to the 3 TB drive, leaving the extra space blank. I upgraded the 3TB to 14.04 3 different times. (I kept crashing 14.04 with various tweak tests.) Finally, I cloned the 3TB to the 1TB to keep a backup of 14.04. All three drives worked!

I decided to upgrade my windows HDD (Seagate 160GB) to Windows 10 so I removed my Ubuntu HDD and disconnected my external USB drive and plugged in the Seagate.
I changed the BIOS boot to Secure-On to boot windows. I ran the updates to Windows 8.1 (which took 8 hours.) I unplugged it and plugged in my 1 TB drive. I did not switch from Secure-On to Secure-Off in the BIOS and got a screen dump (see problem) when I tried to boot. I changed it back to Secure-Off and was able to boot, but was unable to use the NIC with Ubuntu. I tested with all three Ubuntu drives and had the same results. Windows still used the NIC with no problems. (another problem that was solved).

Finally, I tried to boot the 3TB drive with the Windows 8.1 recovery USB plugged in (Meant to have the 14.04 plugged in) and the computer booted 14.04 with the NIC working. It also worked when I had any UEFI formatted USBs installed (12.04, 14.04 live or win8.1.) But, without the USB it would crash.

I was also getting a UUID device failure error at boot time. I identified it in the fstab as follows:
swap was on /dev/sda3 during installation UUID=227f2961-6f7e-4027-ac44-e045fc7e026a none swap sw 0 0

I commented it out and rebooted. The UUID error was gone, but without the USB plugged in, I still got the screen dump problem.

Finally, I turned swapoff in gparted and could boot without the USB plugged in.

Problem:
With swapon when Ubuntu boots after Grub, I get a multi-page "dump" of some sort that pauses awhile and then scrolls again periodically. It does this for hours, but I don't have the patience to see when it might end, so I end up hard-crashing to turn off the computer.

This will continue until I insert any USB flash formatted with UEFI plugged in. I don't have to boot to it, just have it plugged in. Then, Ubuntu boots with swapoff. I can then unplug the USB, reboot and everything works.... until I turn swapon again.

Attempted Solutions (1TB drive only):
- format swap partition - delete and recreate swap partition
- delete sda3 and create sda5 formatted as swap
- resize swap partition

I tried deleting and moving swap partition around. No matter what I do, with swapon I get the screen dump when booting and cannot boot without inserting a UEFI USB. With swapoff, everything seems to work properly. My 12.04 works the same way as well.

Other than turning swapoff on the Samsung or 3TB drive, I have not experimented with them looking for solutions.

** On my active drive, the 1TB, I did extend the /home partition to 400 GB and create a 500GB partition for backups. During that change, I tried again to create a swap partition and had the same results. When I find a solution, I will resize the /home partition and add the swap partition. In the meantime, I will be using the 3TB for experimenting until I find the solution.

*** I read numerous questions about swap problems and find nothing that matches this one.

  • 1
    The "screen dumps" you are getting are messages from the system designed to give you and us an idea what went wrong. They usually contain valuable hints on how to solve your issue. You should therefore not ignore them but read them. In case you did not understand an error given there please edit your question to include it. – Takkat Aug 14 '15 at 11:17
  • That seems impossible. The data dumps probably 10+ pages of text immediately and then three or more pages about every 4 or 5 minutes. I was away from the computer over 3 hours and came back to see it scroll again before forcing a hard-shutdown. When I do boot, I only get about 6 lines in my boot.log file. I would probably have to boot to Live and find the file to upload. If successful, it would be very large. I don't know how to attach a video or I would record the screen to let you see what it does. – Buck Aug 14 '15 at 11:28
  • I am going away this morning for a few hours. I'll try it and see what boot.log says when I look at it from a Live boot. – Buck Aug 14 '15 at 11:29
  • Funny that I could not get it to crash on the 3TB drive, but I did create a new 8GB partition on the 1TB drive and it crashed. I left it about 8:30 EDT and will stop it about lunch time when I get home. I'll try to find the boot.log from a Live USB. – Buck Aug 14 '15 at 14:19
  • After about 2.5 hours of running, I stopped the boot process and booted on a USB Live 14.04 drive. I am able to access the / folder but I can't find the same text I saw on the screen. boot.log was not it, it is just a series of starting and stopping things. – Buck Aug 14 '15 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.