So I recently attempted dual booting Ubuntu with Windows 8.1 on a HP Pavilion G6. So far I've gotten everything working except whenever I turn on or restart my computer, it loads straight into windows. Currently the only way to get into Ubuntu is to get into my UEFI Firmware settings, entering Boot Device options and selecting Ubuntu. I've been researching for the past half an hour and I've tried the following:

  • Disabling fast boot

  • Running a boot repair in Ubuntu (Recommended settings)

  • Typing in cmd in windows

    bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi

Nothing I do seems to work and windows just keeps on loading up.

  • I also got this link when performing a boot repair: paste.ubuntu.com/12078211 – Jakegeyer27 Aug 14 '15 at 10:03
  • Please edit your question, if you want to add information. Overall it's best to have everything relevant in one place. Also, comments may be deleted for various reasons. – David Foerster Aug 14 '15 at 16:02
  • Many HPs have buggy firmware that produces the problem you relate. If the machine is new enough, I recommend you return it for a refund and buy something else. If it's beyond the return period, see this question and answers for some workarounds. (There are many other questions/answers here about this problem, but that's the one I found first.) – Rod Smith Aug 14 '15 at 17:23
  • Another link with similar suggestions. Most with HP copy shimx64.efi inot /EFI/Boot and rename to bootx64.efi. They may have to add a UEFI boot entry if one does not exist or reboot several times to get UEFI to see it. Others have used Rod Smith's rEFInd with good success. askubuntu.com/questions/486752/… – oldfred Aug 17 '15 at 15:22
  • I had the same issue: askubuntu.com/questions/659393/… I ended up using EasyBCD. – redbeard17 Aug 18 '15 at 10:59

You could try installing GRUB, or enabling it, if it's installed:

  1. Boot the machine using a Live CD.

  2. Open a terminal.

  3. Find out the name of the internal disk by using fdisk to look up the device's size.
    For example:

    sudo fdisk -l
  4. Install GRUB boot loader onto the proper disk (the example below assumes it is /dev/sda):

    grub-install --recheck --no-floppy --root-directory=/ /dev/sda


NOTE: you might need to install GRUB... A good guide is this answer.

  • I tried this but when I run the second command with my interal disk, it says grub-install: error: cannot open directory '/boot/grub/i386-pc': No such file or directory. – Jakegeyer27 Aug 15 '15 at 3:54
  • @Jakegeyer27 Are using 64 bit Ubuntu? – TellMeWhy Aug 15 '15 at 18:41
  • yes I am using 64bit – Jakegeyer27 Aug 17 '15 at 11:06
  • @Jakegeyer27 See edit at the end of my answer – TellMeWhy Aug 17 '15 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.