1

If anyone knows whats causing this I'd appreciate it

➜  ~  unity-control-center 

(unity-control-center:1895): Gdk-ERROR **: The program 'unity-control-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 166 error_code 2 request_code 155 (GLX) minor_code 24)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1]    1895 trace trap (core dumped)  unity-control-center

I found a bug report about a Nvidia driver causing something similar but I'm running an Amd driver

0

I did sudo apt-get remove nvidia-346 and sudo apt-get remove system76-driver-nvidia, then rebooted the machine and then System Settings worked.

On a weird side note: I haven't been able to get HDMI working at all (yet displayport did work). After the removal - it worked as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.