I'm using Ubuntu 14.04 and I use the Perapera Chinese add-on for Firefox. It worked up to version 39, but now in version 40 it just stopped working. So I tried to downgrade to version 39 following this link, where there are two options:

1) Choose from the list here, but I have no idea which of the 11 subversions should I use.

2) Download the only version suggested in the link above, i.e. this.

I chose the 2nd option, but after decompressing the file, I have a 'Firefox' folder with lots of files and executables that don't run, just give an error message:

XPCOMGlueLoad error for file (...)/firefox/libxul.so:
libXcomposite.so.1: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

There's a 'run-mozilla.sh', but 'bash run-mozilla.sh' gives:

run-mozilla.sh: Cannot execute .

I REALLY would like to use Perapera add-on to study Chinese. So, is there an easy way to downgrade to Firefox 39? Thanks in advance.

4 Answers 4


You may have two choice to choose for installing method:

  1. Via Mozilla's ftp site (kudos for @Bhikku for sharing the link !). For example we're going to install firefox 50. First, remove any existing version.

    sudo apt-get purge firefox

    Then run following command to download firefox 50 source code, which comes as .tar file.

    wget http://ftp.mozilla.org/pub/firefox/releases/50.0/linux-$(uname -m)/en-US/firefox-50.0.tar.bz2

    Extract the package.

    tar -xjf firefox-50.0.tar.bz2

    Move firefox to /opt directory.

    sudo mv firefox /opt/

    Create symlink in order to set the new firefox as default.

    sudo mv /usr/bin/firefox /usr/bin/firefox_old
    sudo ln -s /opt/firefox/firefox /usr/bin/firefox
  2. Via UbuntuZilla which offer .deb files, to install follow the instruction below.

Remove firefox first :

sudo apt-get purge firefox

Run following command to download firefox :

32 Bit

wget http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt/pool/main/f/firefox-mozilla-build/firefox-mozilla-build_39.0.3-0ubuntu1_i386.deb

64 Bit

wget sourceforge.net/projects/ubuntuzilla/files/mozilla/apt/pool/main/f/firefox-mozilla-build/firefox-mozilla-build_39.0.3-0ubuntu1_amd64.deb

Install it :

32 Bit

cd Downloads/ && sudo dpkg -i firefox-mozilla-build_39.0.3-0ubuntu1_i386.deb

64 Bit

cd Downloads/ && sudo dpkg -i firefox-mozilla-build_39.0.3-0ubuntu1_amd64.deb

And firefox should run the 39 version

Quote from ubuntuzilla official wiki page :

This is the home of the Ubuntuzilla project, hosts an APT repository with .deb repacks of the latest official release versions of Mozilla Firefox, Mozilla SeaMonkey, and Mozilla Thunderbird.

  • 1
    Thanks, Liso, it worked. But isn't it a bit strange that this package should reside in 'ubuntuzilla' @ sf.net? I mean, why can't it be @ mozilla.org? How can I be sure that ubuntuzilla is made by the same guys at mozilla, and not by some hackers?
    – Rodrigo
    Aug 14, 2015 at 1:02
  • 1
    If the work is "just repack", then it's still amazing that Mozilla can't do that themselves...
    – Rodrigo
    Aug 14, 2015 at 11:39
  • 4
  • 1
    @BhikkhuSubhuti Thank you! That feels much safer!
    – Rodrigo
    Sep 15, 2017 at 12:39
  • 1
    @Rodrigo You can also get deb packages from the publishing history in Mozilla's official Firefox launchpad repository: launchpad.net/ubuntu/+source/firefox/+publishinghistory
    – Dan
    Oct 17, 2017 at 9:54

In a terminal run:

apt-cache show firefox | grep Version

You will get a list of available versions like in the list below:

Version: 54.0+build3-0ubuntu0.16.04.1
Version: 45.0.2+build1-0ubuntu1

Install the desired version with:

sudo apt-get install firefox=45.0.2+build1-0ubuntu1

Prevent Ubuntu from upgrading to the latest version:

sudo apt-mark hold firefox
  • 1
    apt-cache show firefox; N: Can't select versions from package 'firefox' as it is purely virtual; N: No packages found
    – Rodrigo
    Aug 1, 2017 at 20:06
  • 3
    This is my preferred method, because it lets me still using the package manager and I plan to use it to go back to the latest version someday soon. Ver. 45 is early enough for us to use with Selenium 2, which is why I'm here.
    – k-den
    Apr 10, 2018 at 20:53
  • That's definitely the answer I was looking for, thank you!
    – Pat Lee
    May 6, 2021 at 9:48

While the normal repository often only contains the latest version for older Ubuntu releases, you may be able to find the previous version with the help of Google.

Generalizing from this blog about Firefox 43 on Ubuntu 12.04, you could search for



sudo apt-get remove firefox
wget "$URL"
sudo dpkg -i "firefox-....deb"
sudo apt-mark hold firefox

The drawback is that you won't get security upgrades for Firefox, so this is only a temporary solution.

  • Sorry, I'm not going to test your solution, just because I solved it a while ago. But thanks for you trying (and helping who gets here in the future).
    – Rodrigo
    Dec 20, 2015 at 22:18
  • 1
    thanks for the apt-mark tip, was getting tired of refusing updates. Jul 22, 2016 at 20:33

This is how I downgraded to Firefox 50 version from version 57.

  1. Go to Firefox Release archive and download a suitable version for you.

  2. Press Ctrl+Alt+T to open the terminal and copy-paste this code:

    sudo apt remove firefox

    To uninstall Firefox current version.

  3. Now, go to the directory where Firefox-.tar.gz( or .tar.gz2) file is kept using the terminal or using file manager. Enter this code( if using the terminal):

    tar -xzf firefox-.tar.gz2

    If using file manager, simply extract the file using the Archive Manager(Look in the context menu).

  4. Open the folder and run the file 'firefox'.

Caution: Don't forget to stop automatic updates in Firefox.

This is the way I did it. Firefox is not installed completely but it still works the way it should. Only the options and the Firefox symbol are not there.

I recommend locking the Firefox in the launcher.

To create a shortcut on the desktop, go to the file and open context menu. Click on 'Make Link'. The file created is to be pasted on the desktop.

Hope this helps!:)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .