I've installed my Ubuntu11.10 yesterday. I updated it and now when i go to shutdown it stucks at Ubuntu logo (the one with the white small balls). I waited 20 mins and nothing, i always have to shutdown by holding the power button. Any suggestions? Thanks :)

  • I've been having similar trouble on my system, since I first got it and installed 11.04 on it. Shutdowns and restarts complete successfully about half the time. Do you know if you're using EFI rather than BIOS? – bgvaughan Oct 14 '11 at 12:33
  • I don't know. How can i detect if i'm using EFI or BIOS? – ocelot Oct 14 '11 at 13:33
  • One way is to check whether you have a grub-efi package installed -- most likely grub-efi-amd64. I should say I don't have real evidence that EFI is the problem; I'd seen it mentioned somewhere that there were sometimes startup/shutdown issues with EFI, but that they'd been cleared up with the Linux 3.0 kernel. – bgvaughan Oct 14 '11 at 17:37
  • You should try booting into recovery mode. If shutdown hangs there too, you can at least get more information about it, because there's no splash screen. If you don't get a menu at boot, try holding the left shift button. – bseibold Oct 25 '11 at 8:47
  • maybe related to this bug: bugs.launchpad.net/ubuntu/+source/network-manager/+bug/875959 – Stefano Oct 30 '11 at 10:18

As I noted in comment, in my case it was related to bug 875959, so a network-manager issue.

Try this command before shutting down:

sudo service network-manager stop

Worked for me.


Do you have mounted samba shares? I've found if I don't unmount them before I shutdown or reboot, my system hangs.


Having this problem also very rarely. Seems it shows up after certain updates have been installed. If it happens, I'm just giving it some time just to be on the safe side (took a long time for the first shutdown after installing gnome3/gnome-shell), then I reboot with Alt Sysreq REISUB . Next shutdown(s) are usually fine again after that.


I also have the same problem. And I tried everything I can think of, like update-grub, remove samba. But after I removed the AMD/ATI additional driver, that never happens again. So I think this is caused by some bugs in additional driver.


Same problem here.

Stopping network-manager won't help.

It is maybe related to an rpcbind issue (https://bugs.launchpad.net/ubuntu/+source/rpcbind/+bug/844317?comments=all) as on shutdown I get:

rpcbind: rpcbind terminating on signal. Restart with "rpcbind -w"

Sometimes the kernel fail to kill all remaining processes, some other times it succeeds, however the system is not powered off and I need to either hold the power off button or press Alt+SysRq+B to reboot.


Try to change the init level (order) of the network manager during shutdown and maybe solve the issue? In the init config, the order of shutodown of services is defined ( I think). Its possible you could change the order so the network manager stops first during shutdown?


Happens to me sometimes. It might have been a coincidence, the way I solved it, but when I took the computer from my room to the living-room and then back again, when I unplugged the power supply, I accidentally touched the power supply cord's end. I got a nasty shock... My hand was feeling a bit numb. The cord's end is the two metallic pins you plug onto the socket.

Strangely, when I turned the computer on, worked a bit and turned it off, I was with my finger on the shutdown button, thinking that I would have to manually shut it down.

4 seconds later, the computer shutdown.

Conclusion: It might be that your computer is overcharged with electricity. I do not know if it is healthy to discharge it like I did, though; poor hand of mine :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.