1

installed Ubuntu 14.04 in a external hard disk because in the internal hard disk I have Windows 10 and very low space.

When I try to boot the external HD, sends the Grub Recovery. I saw few tutorials, but nothing, I hope that somebody help me. This is my info:

Disk /dev/sda: 120.0 GB, 120034123776 bytes

255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes Disk identifier: 0xd90da8d6

Device Boot Start End Blocks Id System

/dev/sda1 * 2048 1026047 512000 7 HPFS/NTFS/exFAT

/dev/sda2 1026048 234439599 116706776 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes

255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x03dd0735

Device Boot Start End Blocks Id System

/dev/sdb1 16126 199093544 99538709+ f W95 Ext'd (LBA)

/dev/sdb2 * 199109607 1704367979 752629186+ 7 HPFS/NTFS/exFAT

/dev/sdb3 1704367980 1726537679 11084850 82 Linux swap / Solaris

/dev/sdb4 1726537680 1953520101 113491211 83 Linux

/dev/sdb5 16128 199093544 99538708+ b W95 FAT32

  • Did the installation of Ubuntu boot previously? If so, what has occurred between your last boot and now? – user323419 Aug 13 '15 at 14:51
  • Is the first time that I do this, previously I install linux alongside Windows in the same hard disk – Sirious Mouth Aug 13 '15 at 14:58
  • What method of installation did you use? – user323419 Aug 13 '15 at 15:10
  • I unplugged the internal hard disk and I choosed "something else", I already had the swap and the ext4 partitions, only I made a format from the ext4 partition and install linux. – Sirious Mouth Aug 13 '15 at 22:13
  • Where did you install grub to? If you installed it on the Ubuntu partition, it won't work. You need to install it on the MBR – user323419 Aug 13 '15 at 23:39
0

Your issue is most likely that the GRUB bootloader was not correctly installed during initial set-up. To remedy this, you are going to have to reinstall Ubuntu; which, considering you have not yet booted into it, should be relatively unobtrusive. Do it the same way you installed previously, by selecting "Something Else..". However, when you get to the partition menu, you should notice a drop-down menu for where the bootloader should be installed. By default, it chooses the first available option. When installing to an external HDD, you need to install GRUB onto the Master Boot Record (MBR) of that drive. So, in the dropdown, you will see something similar to /dev/sdX1 /dev/sdx2 and so on, where X is the letter assigned to the HDD you are working on. You will need to select the /dev/sdX option, without a number associated with it. For example, if you are installing Ubuntu on /dev/sdb1, you will install the bootloader to /dev/sdb.

Additionally, as you are working on Windows 10, you may have the same issue that Windows 8/8.1 have with the system wanting only to boot Windows due to secure boot being enabled. You will have to disable this "feature" of Windows on newer computer models. You can do this in your BIOS settings, which differ from computer to computer. Most often, though, you will see the option as you boot to "Press F12 to Enter Set-Up" or something similar. Press the indicated key, navigate through your BIOS menu to Boot Options, and disable "Secure Boot".

UPDATE: After some fooling around in a virtual machine, I was able to replicate your issue. By default, GRUB installs to the first partition found. You probably accidentally installed it on the first partition of your internal hard-drive when you attempted your first install. This probably means you wrote it over your Windows partition. The best you can do here is try to find a Windows 10 Boot repair disc and repair the boot partition of your internal drive. Then, Windows will be able to boot. When installing Ubuntu onto the external drive, you will not be able to go through the regular boot process to start Ubuntu. Rather, you will have to change the boot order of your machine so that it boots from USB first. This process differs depending on your BIOS.

  • I did all the steps you mentioned and it won't work, sends me the same GRUB RESCUE > :'( – Sirious Mouth Aug 14 '15 at 17:05
  • Did you physically disconnect the internal hard-drive when installing? If so, try NOT doing that. Just let it go ahead and detect the Windows disk during installation. As long as you make sure you only install things to the external, you should be fine. – user323419 Aug 14 '15 at 18:54
  • I don't disconnect the internal, and don't recognize windows 10 – Sirious Mouth Aug 14 '15 at 20:12
  • @SiriousMouth I updated the answer with what probably happened. – user323419 Aug 18 '15 at 19:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.