3

I installed Ubuntu 11.10 yesterday. From the repos I installed postgresql and pgadmin3. postgresql 9.1 is the current version but it seems pgadmin3 v1.12 is not properly compatible with 9.1.

How can I update it to use pgadmin3 v1.14? I have tried to add this PPA https://launchpad.net/~rhonda/+archive/pgadmin3 but after I reload my sources I just get an error.

Thanks

4

You can try:

sudo apt-add-repository ppa:flexiondotorg/postgres
sudo apt-get update
sudo apt-get install pgadmin3

or

sudo apt-add-repository ppa:voronov84/andreyv
sudo apt-get update
sudo apt-get install pgadmin3

Worked for me.

1
  • for postgres 9.2 compatibility, only the last one works, it installs version 1.16.0 – Laurent Debricon Sep 16 '12 at 19:10
2

think i fixed it. you've got to sudo gedit /etc/apt/sources.list.d/rhonda-pgadmin3-oneiric.list and change oneiric to natty.

then run sudo apt-get update and if you open the package manager now you should see the new version of pgadmin3.

4
  • I'm having exactly the same problem. PPA you are linking to provides beta-1 version only now. Could you please comment on stability/usability of this version? – radek Oct 25 '11 at 18:38
  • @radek it is beta-1 but working fine for me :) – darren Oct 29 '11 at 12:51
  • yup - working fine for me too :] – radek Oct 29 '11 at 15:09
  • didn't work for me. i don't have rhonda-pgadmin3.oeriric.list – Asken Nov 14 '11 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.