0

Since I am working with X10, I got the X10 language highlighting for gedit. This works, but whenever I open an .x10 file I first have to change the "Highlight Mode" to "X10", otherwise there is no highlighting at all. How do I make gedit auto-detect .x10 files?

0

If X10 files are not highlighted by default you can activate Snippets plugin. I assume you have set the .lang file under /usr/share/gtksourceview-3.0/language-specs. From plugin you can activate x10 highlightniing by shortcuts or snippet name followed by Tab key. I am not sure what Drop target option is for, nevertheless there is no way make it auto-detect IMHO.

I know this is not what you've been looking for but it will ease the trouble :)

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.