0

this is my first question at here, so please be gentle if do something wrong.

I have Ubuntu 14.04.03 LTS installed on my laptop. Also i have working dual boot to Windows 10 with UEFI activated.

My laptop is warming up too much faster than Windows, tempature never downs below 65 C.

I search this problem a bit and i see posts about bumblebee Nvidia drivers etc. So i decide to install proper Nvidia drivers to use Nvidia GTX960m only when i choose.

For that i had to install Nvidia drivers first, but when i tried and reboot i cant pass the login screen. When i check xsession-erros file, i see some erros like that;

Xlib:  extension "GLX" missing on display ":0.0".

I had to remove all nvidia packages to correct this situation and login again. What am i doing wrong?

Also i'm open advices for any other choices. I just use Ubuntu for developing at Ruby; so i dont need to use Nvidia GTX960m really. I just want to keep my laptop cool ( make as much as ) and last longer at battery.

Thanks!

Ps: English is not my native language, if i spelled something wrong; i'm sorry.

1 Answer 1

0

The below answer is only applicable if your laptop has nvidia Optimus:

I got my optimus laptop working with bumblebee/nvidia. Temperature is ~48C idle

Basically you do this:

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update

sudo add-apt-repository ppa:mamarley/nvidia

sudo apt-get update

install bumblebee and the nvidia driver

sudo apt-get install bumblebee bumblebee-nvidia nvidia-352 nvidia-352-uvm nvidia-settings

then you need to sudo gedit /etc/modules and add

i915

bbswitch

then you need to sudo gedit /etc/modprobe.d/bumblebee.conf and make sure the line

blacklist nvidia-352

is there, if not add it.

finally you need to sudo gedit /etc/bumblebee/bumblebee.conf

line 22: >Driver=nvidia

line 55: >KernelDriver=nvidia-352

line 58: >LibraryPath=/usr/lib/nvidia-352:/usr/lib32/nvidia-352

line 61: >XorgModulePath=/usr/lib/nvidia-352/xorg,/usr/lib/xorg/modules

reboot.

This answer comes from: http://rajat-osgyan.blogspot.gr/2015/05/how-to-install-latest-nvidia-driver-in.html

see there for more explanation. It is approved by many (and me)to work, though the difference is that i don't use ppa:xorg-edgers (since it is unstable) and use ppa:mamarley/nvidia and ppa:bumblebee/stable, i recommend you do that instead.

Games run "almost" fine and i can use my both my cards simultaneously.

intel core i5-3210m, GT 650M

P.S what do you mean by "proper" nvidia drivers?

1
  • Thanks for your answer! But i was found my solution 2-3 days ago with doing format. After that i used xorg-edgers ppa and install nvidia 352 and prime to get it work. So far i get 48-49C when idle. Thanks anyway!
    – Okan Binli
    Aug 18, 2015 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.