3

I have installed Ubuntu 15.04, Gnome Panel(gnome-session-flashback) and Dropbox. Dropbox icon is missing in the top panel. However, it is displayed corectly when I run Unity. I tried stop and start Dropbox, reinstall it but it is not working.

Update: It seems there are more broken things for me than working, so I am going to install 14.04 LTS.

  • Try run sudo apt-get install libappindicator1 – Jim Aug 13 '15 at 14:26
  • I tried that before posting and it was already installed. – grxx Aug 13 '15 at 16:30
4

libappindicator1 may be the answer but in many cases it isn't.

The following has been submitted to www.dropbox.com as a bug but linux users don't appear to be a high priority.


In dropbox's preferences, if you check Start Dropbox on system startup, the daemon will start and dropbox will be working in the background, but the icon will not appear. This is apparently because the dropbox autostart config file ~/.config/autostart/dropbox.desktop insists on setting a startup delay of zero but displaying the icon requires some other process to be running already... and in many cases it is not, especially when a number of other startup applications are starting up / running.

In Ubuntu's System Settings/Startup Applications, if you set the startup delay for dropbox to 10 seconds or more, the process works properly and the icon appears... once. Then dropbox resets its startup file ~/.config/autostart/dropbox.desktop back to a delay of zero and the problem returns.

Workaround: uncheck the dropbox's preference Start Dropbox on system startup, write a short script that starts dropbox, add the script to Startup Applications and set the delay to 10 seconds or more as needed by the Ubuntu distro and by other startup settings.

Permanent fix: dropbox should stop rewriting the delay in the autostart file ~/.config/autostart/dropbox.desktop or make the delay a preference.

Sample script:

 #!/bin/bash
 dropbox stop  #because the actual daemon usually IS running
 dropbox start
 exit

Save it as something like fix-dropbox-icon.sh. Remember to make it executable in the permissions.__

Unrelated point of interest. After doing this I reviewed my Startup Applications list and changed everything that I don't consider immediately vital for a startup delay of 30 seconds or more. Now my Ubuntu startup is MUCH faster. Of course I have a lot of stuff there. Your results may differ.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.