I installed 11.10 this morning, and all seemed fine - slightly transparent windows and all. I installed it 'over the top' of 11.04 - that is, not through the update dialogue, and it worked fine.

I decided to make my launcher icons smaller, so opened CCSM, and clicked the second choice down in the left hand pane (didn't alter any settings) and it crashed completely. I had to hold the power button, and when I restarted it, all I have visible anywhere is a File Edit View menu across the top, and my Spotify icon on the desktop. Nothing to log in, log out, nothing visible anywhere, no application menu, no launcher, nothing.

I'm at a loss as to what to try. I can open a terminal, but I have tried (perhaps incorrectly) to close and restart both Nautilus and Unity, and neither did anything (assuming I was doing it right)

Any thoughts, or shall I reinstall?

  • 1
    perhaps you could try unity --reset to give unity a fresh restart. Might help. – nik90 Oct 14 '11 at 9:53

Looks like the Compiz Unity plugin is accidentally deselected. Press Ctrl + Alt + T and type unity --replace and you would have your Unity back. Alternatively, if you have CompizConfig Settings Manager (CCSM) installed in your computer, you can type ccsm in Terminal and run the program. There, under the desktop heading, you can select 'Ubuntu Unity plugin' and your Unity would be back to normal.

  • I had this same problem, my plugin was disabled. This is probably your best bet. However, if Ctrl+Alt+T doesn't give you terminal, try Ctrl+Alt+F1, then type your username and password in, the run "ccsm", the press Ctrl+Alt+F7 to return to your desktop. – Ryan McClure Mar 18 '12 at 16:27

I booted into recovery mode and fixed broken packages. This worked for me.

  • 1
    Can you advise me how to do this (fix broken packages)? Can't remember the shell command. Sorry to be a pain – user27072 Oct 14 '11 at 10:57

I think this problem is connected to the graphic drives. When I install the proprietary drivers (ATI), it seems to work - but Gnome Shell is horrible. I on the other hand can't install the post release ATI drivers, I get a message that something is wrong with /var/log/jockey.log

I wait for the fix of that bug (?) - when I uninstalled the proprietary drivers, both Unity and Shell was not accessible to me.

EDIT: After a long try I got back to "radeon" and everything seems to work more or less.


I will have to agree Extender. I had this issue and removing the compiz config files fixed it.

cd ~/.config/compiz.. rm -rf compizconfig/

will remove the files and directories. Your computer will probably lock up for a few moments then everything should kick back to right where it was.


First, try the post from my blog to see if resetting the gnome panels fixes it. http://dageek247.tk/wordpress/?p=76

If you use unity, instead look at this blog post: http://www.webupd8.org/2011/04/how-to-reset-unity-launcher-icons-or.html

Next, try installing the proprietary drivers for your system to see if that works. http://www.ubunturoot.com/2011/09/installing-latest-proprietary-display.html

Last, try formating the partition and trying again.


You can remove compiz config files from home directory: ~/.config/compiz. That worked for me.


If nothing else works, you can disable the Compiz Unity plugin while unloading and loading other plugins (clearing and removing their checkmarks).

It seems to be a bug specifically in Unity.

  • That's rather a workaround then a solution, but might be acceptable. ;): – Mateng Nov 19 '12 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.