I have problem with Firefox on Ubuntu. When I scroll on facebook or youtube it doesn't scroll smoothly like it used to on Windows. It's hard to explain but main point is when I scroll down/up it doesnt go smoothly and it's obvious.

  • Post a screenshot, is your scroll bar like this ?
    – Liso
    Aug 12 '15 at 23:39
  • More information needed: Please identify if this is screen tearing (look it up), or specific to the mouse (driver). Confirm if this only occurs for Firefox, and (if so) what video chipset/card and driver you are using.
    – david6
    Aug 13 '15 at 1:31

Firefox 46 brought GTK3 integration and true "pixel-perfect" scrolling for touchpads.

To enable it, you must set the MOZ_USE_XINPUT2=1 environment variable. There are a number of ways to do this, one of them would be to add it to /etc/environment and then reboot the machine:

echo MOZ_USE_XINPUT2=1 | sudo tee -a /etc/environment
  • This made no difference for me. Jan 24 '17 at 18:55
  • Put it in ~/.bashrc or ~/.xsessionrc.
    – iLikeDirt
    Jun 10 '17 at 23:19

I had this problem and for me, the fix was to set gfx.webrender.all to true in about:config. I have no idea why that fixed it or what it does.


First of all, this is basic. Unplug your mouse, and re-plug it back in, into a different USB port on your computer. This may just be a loose connection. If that doesn't solve it, keep reading.

The problem could be a certain number of things, but I've narrowed it down to 2 possibilities.

  1. Your mouse scroll wheel is having problems communicating correctly with Mozilla Firefox.

  2. Mozilla Firefox is having other problems, like not finding drivers for your mouse, or simply not connecting to it sometimes.

What I'd like you to do is download another web browser such as Google Chrome, and tell me if the scroll still isn't working. If so, it's a problem with your mouse/mouse drivers. If it does work on another browser, It's a problem with Mozilla. To fix the mouse drivers, just look up ('Mouse Brand Here') Mouse Drivers and download & install them. If it's a problem with Mozilla, just uninstall Mozilla, and reinstall it. If it still doesn't work, leave a comment.

  • 2
    This answer is generic enough to be for an unskilled Windows user, and have been posted on Mozilla's old help pages. It includes steps and practices that are NOT recommended for (Ubuntu) Linux. Can you please provide sources or this 'wisdom'.
    – david6
    Aug 13 '15 at 1:28

I installed Ubuntu LTS 20.04 and Firefox scrolling wasn't as smooth as in other apps.

I followed advice from this link : in about:config, set layers.acceleration.force-enabled to true

Keywords for french readers: défilement doux de firefox saccadé

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.