0

I was using Windows 10 and decided to install Ubuntu, my internet works extremly slow. On Windows 10 it worked perfectly fine. edit:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 09)
    Subsystem: ASUSTeK Computer Inc. P8H77-I Motherboard [1043:8505]
    Kernel driver in use: r8169
4
  • 1
    What is your "internet"? Wired, wireless or what?
    – Pilot6
    Aug 12, 2015 at 22:38
  • Wired, model of router huawei hg530
    – Luke Flip
    Aug 12, 2015 at 22:44
  • Please edit your question and add output of lspci -knn | grep Eth -A2 terminal command.
    – Pilot6
    Aug 12, 2015 at 22:46
  • Pilot6, I've just done it. :)
    – Luke Flip
    Aug 12, 2015 at 22:47

2 Answers 2

0

Run in terminal

sudo apt-get install r8168-dkms

and reboot.

This will install another driver. It should work better.

4
  • I tried and got some kind of error, here is 'log' pastebin.com/LG9EbHjW
    – Luke Flip
    Aug 12, 2015 at 22:51
  • At the end I think I installed it, reboted but it works pretty simillar..
    – Luke Flip
    Aug 12, 2015 at 23:03
  • One thing that might help, even though it's not driver related, is to change DNS settings. I've got my DNS set to Google DNS 8.8.8.8 as primary, and 8.8.4.4 as secondary. It's a noticeable improvement as far as loading time for webpages. Aug 13, 2015 at 2:35
  • @LukeFlip And what is in that make.log?
    – Pilot6
    Aug 13, 2015 at 6:52
0

i don't think r8168-dkms compiles. Use solution from here, this one works fine, although you can not upgrade kernel without having to recompile. Somehow, it only worked for me if I compiled as root:

apt-get install build-essential linux-headers-`uname -r`
wget http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0002-r8168-8.040.00.tar.bz2
sha256sum 0002-r8168-8.040.00.tar.bz2 
 --> da0444fcd7aabb7762310cdf2047fd0aeb7a9ed97a3d6b80d62a0fc71e0730bf  0002-r8168-8.040.00.tar.bz2
tar -xjf 0002-r8168-8.040.00.tar.bz2 
cd r8168-8.040.00/
sudo make
sudo make install

then you need to blacklist r8169, cross fingers and reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.