2

I'm running into inconvenience because the global password manager (gnome keyring?) that should fill in auth dialogs in Chromium doesn't trigger. For example, I'm accessing some webpage that asks for basic HTTP auth, or simply a login form I've already accessed and for which Chromium has already stored my credentials.

The expected flow would be

  • the global pw manager popping up once per session, the first time I load the page (or periodically in a session, like sudo works, for example),
  • demanding my password,
  • then filling in the browser auth dialog.

Instead, nothing happens, unless I sidestep this by doing some other action that finally triggers the password manager, e.g. installing-uninstalling some program in Ubuntu's software center. After triggering the password dialog in this manner, and refreshing the relevant pages in Chromium, passwords and credentials are filled in as expected, but this is far from ideal. I cannot find links to other people experiencing this problem. Does anybody know how to solve this?

It seems I'm running into a similar issue as the one detailed in this SU question. In my case, both "Enable Autofill..." and "Offer to save passwords..." are checked. When I first login (autologin is enabled), e.g. when turning on the computer, the Saved Passwords list is empty. After doing something that requests the global password manager's attention, such as the aforementioned installing something through the Software Center, the list is full of stored credentials.

I checked, and it doesn't seem to be a difference between starting a session with automatic login (where I don't have to input my password) or starting my session by entering a password (I tried closing the session, the system then asked me for my password, but autofill was still unavailable.)

I checked Seahorse, and I see two different password keyrings: the "Session Start" one, which only contains one item: "Unlock password for Default (Google Chrome password)" and the "Predeterminado" keyring, which indeed holds all my Google Chrome passwords, and probably more. Problem is, the "Default" keyring is not unlocked by logging in.

I also tried replacing the "login" keyring with the "Predeterminado" (Spanish for "Default") one, as mentioned in this answer, but that didn't work either, and in fact that made the chromium password autofill stop working entirely.

  • Please specify what is your goal. Are you annoyed of entering a password or do you want to be asked for a password each time you go to a web site? – Pilot6 Aug 14 '15 at 21:57
  • "The expected flow would be the global pw manager popping up, demanding my password, then filling in the browser auth dialog. Instead, nothing happens." – user26592 Aug 14 '15 at 21:58
  • Please read the question. What I expect to happen is right there. If I don't have to enter the password after login, all the better. But I'd be happy with entering it once (or periodically). – user26592 Aug 14 '15 at 21:59
  • You can achieve this by not saving your passwords in your browser. You can clear all passwords in the settings, and you will have to enter them again each time you visit the site. – Pilot6 Aug 14 '15 at 22:01
  • The point is in a secure password storage. If someone steals your computer, he will not be able to access your web passwords without the master password. – Pilot6 Aug 14 '15 at 22:04
1
+25

You mix up two separate issues.

Gnome-keyring stores passwords for websites and other passwords, like ssh, gpg, etc.

The keyring is unlocked when you login into the system and does not require to enter master password again. That is normal behavior.

When you try to install some software, you need to have an administrator privileges. In Ubuntu you do not have to login as root, but sudo lets you execute a privileged task from a user account, but asks to enter a password again.

These two scenarios are not related. And this is not a problem at all.

  • So. The fact that the dialogs in Chromium asking for a password don't work until I trigger the keyring by using the software center, and work afterwards, have nothing to do with this. And me having to workaround the problem in this way is not a problem at all. This is not a useful answer. – user26592 Aug 14 '15 at 21:50
  • The system is designed this way. If you enable login without entering the password, keyring will ask you the password to unlock the storage. If you enter the system with a password, it will not ask you again. But you can change this behavior by starting chromium with --password-store=basic, but it is less secure. – Pilot6 Aug 14 '15 at 21:55
  • The system is doing that it is designed to do. Maybe you do not like it. But I am trying to explain what it does. What do you think is a "useful" answer? – Pilot6 Aug 14 '15 at 21:59
  • Yes, if you don't like how Ubuntu works, you can go back to Windows, if you like it. That's your choice. – Pilot6 Aug 14 '15 at 22:02
  • 1
    "Gnome-keyring stores passwords for websites and other passwords, like ssh, gpg, etc. The keyring is unlocked when you login into the system and does not require to enter master password again. That is normal behavior." The whole point of my question is that the keyring is not unlocked, so I can't get to the stored passwords. Can you read that? – user26592 Aug 14 '15 at 23:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.