2

I tried to get dnscrypt-proxy working from this PPA: https://launchpad.net/~anton+/+archive/ubuntu/dnscrypt

EDIT: this PPA is outdated, and the correct one to use is https://launchpad.net/~xuzhen666/+archive/ubuntu/dnscrypt

After installing, it complains about upstart not being available.

➜  ~  sudo apt-get -f install
Setting up dnscrypt-proxy (1.6.0-3pmo1~vivid) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
insserv: warning: script 'dnscrypt-proxy' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `dnscrypt-proxy'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `dnscrypt-proxy'
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
Failed to restart dnscrypt-proxy.service: Unit dnscrypt-proxy.service failed to load: Invalid argument. See system logs and 'systemctl status dnscrypt-proxy.service' for details.
invoke-rc.d: initscript dnscrypt-proxy, action "restart" failed.
dpkg: error processing package dnscrypt-proxy (--configure):
 subprocess installed post-installation script returned error exit status 6
Errors were encountered while processing:
 dnscrypt-proxy
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'd rather not switch back to upstart if not needed. Do I have to wait on the package maintainer to update the package for systemd?

I cannot remove the package with dpkg or apt-get because it tries to shut down the service and fails with similar errors.

Removing dnscrypt-proxy (1.6.0-3pmo1~vivid) ...
Failed to stop dnscrypt-proxy.service: Unit dnscrypt-proxy.service not loaded.
invoke-rc.d: initscript dnscrypt-proxy, action "stop" failed.
dpkg: error processing package dnscrypt-proxy (--remove):
subprocess installed pre-removal script returned error exit status 5
...

Running the command shown in the error log above:

~ systemctl status dnscrypt-proxy.service
dnscrypt-proxy.service - DNSCrypt proxy
Loaded: error (Reason: Invalid argument)
Active: inactive (dead)
 Docs: man:dnscrypt-proxy(8)
systemd[1]: dnscrypt-proxy.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.
  • In this case you should ask the developer. – A.B. Aug 12 '15 at 14:13
  • How can I remove it in the mean time? – timelf123 Aug 12 '15 at 14:14
  • Try a sudo apt-get purge dnscrypt-proxy – A.B. Aug 12 '15 at 14:16
  • And if ppa-purge is installed: sudo ppa-purge ppa:xuzhen666/dnscrypt – A.B. Aug 12 '15 at 14:17
  • The apt-get purge results in the same type of error, see second from last error above – timelf123 Aug 12 '15 at 14:17
2

Seems to be a bug, you should ask the developer. In the meantime remove the package.

  1. Check the file /var/lib/dpkg/info/dnscrypt-proxy.prerm, the pre-removal script and search for the command to stop the service, anything like service … stop. Comment the lines out and try it again. I will check this later at home to give a better explanation.

  2. sudo apt-get purge dnscrypt-proxy

|improve this answer|||||
  • Don't thank me! ;-) If you like my answer, just click the little grey under the "0" now turning it into beautiful green. If you do not like my answer, click on the little grey down-arrow below the 0, and if you really like my answer, click on the little grey checkmark and the little up-arrow... If you have any further questions, go to askubuntu.com/questions/ask – A.B. Aug 12 '15 at 15:46
  • :D I like the comment! +1 VTC – Fabby Aug 12 '15 at 19:07
  • @Fabby Nice comment, isn't it? Why VTC? – A.B. Aug 12 '15 at 19:09
-2

You could try this:

sudo apt-get install linux-efi-amd64_ linux-efi
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install -f
sudo apt-get install linux-efi

and then this:

sudo -i
mkdir /com/upstart
sudo nano /com/upstart/upstart

and then write this:

[default]
plymouth-upstart-bridge=default

and it might work fine this way.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.