0

World of Warcraft is lagging

My PC is does not have the latest hardware. But thing is when I was running Windows I could tweak it and set it to lowest performance and the game was running just fine. But it dose not seem to work in Ubuntu. Also one thing, when I switch to desktop, and go back to the game, the freeze.

What am I doing wrong

Graphic: GeForce 210/PCIe/SSE2
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ × 2
RAM: 6 GB
OStype 64-bit
Disk space, 300 GB

1
  1. Use the latest Nvidia drivers

    sudo apt-add-repository ppa:xorg-edgers/ppa
    
  2. Open the Registry-Editor (part of the package wine)

    regedit
    
  3. Create a new key

    • Select the path below

      HKEY_CURRENT_USER\Software\Wine\
      
    • Right click and select

      New > Key

    • Use the name

      DisabledExtensions
      
  4. Enter the value

    • Double click the cell in the table in the right pane in the column Data

    • and enter

      GL_ARB_vertex_buffer_object
      

    enter image description here

  5. Use OpenGL

    • Open the file ~/.wine/drive_c/Programme/World of Warcraft/WTF/

      nano ~/.wine/drive_c/Programme/World of Warcraft/WTF/Config.wtf 
      
    • Add the line

      SET gxApi "opengl"
      
    • To deactivate anti aliasing, add

      SET ffxGlow "0"
      
  6. Configure wine

    • Start with

      winecfg
      
    • Use the tab Graphics

      Activate Allow the window manager to control the windows

      Activate Pixel Shader (not in the screenshot, because it's not supported in my case)

    enter image description here

  7. Enjoy :)

  8. If you have more problems, try the settings below, in ~/.wine/drive_c/Programme/World of Warcraft/WTF/Config.wtf too

    • Graphic

      SET ffxDeath "0"
      SET ffxGlow "0"
      
    • Neon colors

      SET pixelShaders "0"
      SET M2UsePixelShaders "1"
      SET M2UseShaders "0"
      
    • Sound

      SET SoundOutputSystem "1"
      SET SoundBufferSize "150"
      

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.