2

My first problem was that playing videos made everything freeze - totem was using almost all my cpu power. To solve this I installed nvidia drivers with

sudo apt-get install nvidia-###

Where ### was a number I found using http://www.nvidia.com/Download/index.aspx (for my card Geforce 630M).

This seemed to work. Video playing no longer froze my laptop (which is an Acer Aspire V3-571g if it matters). However, when I connected a second monitor I got some issues. Half of the second screen would be "cut off", only showing black. Entering nvidia-settings only showed the laptop screen

To solve this I found various questions and forum threads suggesting to do install nvidia-current instead. I did that, and ever since the GUI hasn't worked. I've tried things like

sudo apt-get purge nvidia*

and I've tried removing that /etc/X11/xorg.conf file - nothing has worked so far.

Any suggestions on what I can do?

Edit: I'm getting "Unable to connect to X server" now, when I go into terminal with ctrl+alt+F1.

UPDATE: I didn't manage to solve the problem, and in the end I just reinstalled Ubuntu.

5
  • Could you try this first and then report back by leaving a comment @Fabby – Fabby Aug 13 '15 at 17:03
  • 1
    Thanks @Fabby - I hadn't seen that answer. It would've saved my a lot of time googling, but I couldn't find anything in there that I hadn't already tried. In the end I reinstalled ubuntu and I'm using the nouveau drivers without great issues. If I try to use the nvidia drivers again, I'll update here on how it goes. – L42 Aug 14 '15 at 7:23
  • 1
    I wouldn't say that the problem went away - I'm still unable to use ubuntu. Everything freezes when playing videos, and while nvidia-drivers solves that I'm then unable to use multiple monitors. Just looks like nvidia doesn't play well with ubuntu :) – L42 Aug 14 '15 at 19:31
  • IMHO, It's still better to let the closure run its course and ask a new specific question with your new system. In the mean time you know more already, so your question will be more specific! ;-) – Fabby Aug 14 '15 at 19:39
  • I agree! I was just curious whether it would get a "solved"-tag or something :) Thanks again! – L42 Aug 15 '15 at 10:20
0

"Ubuntu 15.04 seems to have an issue with nvidia drivers." This is a common problem...

First, lets get Ubuntu to a 'clean' state, without any nvidia drivers installed:

sudo apt-get purge $(dpkg -l | awk '$2~/nvidia/ {print $2}')

Next, let's remove the x-server error - follow this guide.

Now, we'll try to set up the Nvidia GT 630 drivers:

sudo apt-get install nvidia-304 nvidia-304-updates

If it still doesn't work, then try upgrading your kernel

sudo apt-get install linux-generic

And try again...

You can install the latest NVIDIA drivers by adding the new PPA to your system.

To do so:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update && sudo apt-get install nvidia-355

And as OMG! Ubuntu! say:
Remember: if the PPA breaks your system you are allowed to keep both halves. ;D

12
  • Thank you for answering, but it didn't work. I first went to the folder with the .run file and ran > sudo bash NVIDIA-Linux-x86_64-352.30.run --uninstall Then I did everything else, though I didn't have xserver-xorg-video-nv installed. But in the end I got the same result as before - background image showing but nothing working. – L42 Aug 12 '15 at 11:47
  • @L42 You ran what? – TellMeWhy Aug 12 '15 at 11:51
  • sudo bash NVIDIA-Linux-x86_64-352.30.run --uninstall – L42 Aug 12 '15 at 11:55
  • @L42 New edit, perhaps it will work for you. Most likely it won't... – TellMeWhy Aug 12 '15 at 12:01
  • 1
    Thank you for all your help! I've tried what you said (kernels I tried at an earlier point), but I've still got the same problem. I'm gonna go ahead and reinstall ubuntu and stay away from the nvidia drivers. – L42 Aug 12 '15 at 13:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.