13

Which IDLE package I should install from Software Center in Ubuntu assuming I want to program in Python 3?

19

You can install IDLE for Python 3 by installing the idle3 package in the official Ubuntu repositories:

sudo apt-get install idle3

For Python 2, replace idle3 with idle.

  • 1
    When I ran the code and installed idle3, it also installed idle-python3.4 alongside. I assume it is not idle3 itself that actually runs when I run it on command terminal but rather idle-python3.4. idle3 itself is just pointing at it. If a new version (say idle-python3.5) is released, it downloads that and idle3 starts to point at that from that moment on as far as I understand. Is this correct? – SarpSTA Jun 25 '17 at 18:45
  • 1
    @SarpSTA Yeah I would expect that to happen automatically. – edwinksl Jun 25 '17 at 19:00
3

Use this package. Any of IDLE3 packages are fine. If you install IDLE3 it will get updated when they release a new version of IDLE3. But if you install IDLE(using Python-3.4), it won't get updated when IDLE for 3.5 is available.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.