1

I can't log in to my home directory after user creation: I reinstalled my system fresh (Ubuntu 14.04.3). Created an admin user. Added my main user with adduser me. I get feedback along the lines:

Home directory created, copying files from /etc/skel

The directory is listed in /etc/passwd and it is owned by me, with 755 permissions. also, usermod -d /home/me me gives: no changes

Still, the terminal logs me in with: No directory, logging in with HOME=/ and the graphical login throws me back to the login screen.

Anything else I can try?

  • Silly question, but does /home/me actually exists? You never stated this explicitly. Have you checked? – kos Aug 12 '15 at 1:11
  • well yes, it is owned by me with 755 permissions. it exists. – TNT Aug 12 '15 at 1:13
  • 1
    $HOME might be being set wrongly, try export HOME=/home/me, su me and see if you get the same error – kos Aug 12 '15 at 1:27
  • That was indeed set wrong: echo $HOME: /. I set it as you said, still didnt fix it, or rather I couldn't permanently change it when logged in as me, it would jump back after re-log on. only then I realized the parent directory /home was owned by the first created admin user for some reason, permissions 700. Setting those to 755 now I can log in successfully. Thanks. – TNT Aug 12 '15 at 1:51
  • Glad that you solved, tough I don't know how that could have happened. However /home should be owned by root:root, you might want to fix that as well – kos Aug 12 '15 at 1:59
1

It turned out somehow the /home directory was owned by the first created admin user for some reason, with permissions 700. Changing the owner back to root:root and setting permissions to 755, now I can log in successfully with user me.

  • 1
    right, that slipped my mind, I updated the answer, thanks. – TNT Aug 12 '15 at 3:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.