2

When entering this dpkg-source -b <packagename> into the terminal to create a debian source package, I get the following error:

dpkg-source: error: syntax error in ResolutionX_1.0-0/debian/control at line 9:
first block lacks a source field

What does this mean?

My debian control file contains:

Package: ResolutionX
Version: 1.0-0
Section: base
Priority: optional
Architecture: all
Build-Depends: debhelper (>= 9)
Maintainer: xx 
Description: ResolutionX
    A simple tool to enable you to have your desired resolution without requiring graphics drivers.
  • Well, what does ResolutionX_1.0-0/debian/control contain? At least the first 10 lines of it? – muru Aug 11 '15 at 17:43
  • @muru see edit. – TellMeWhy Aug 11 '15 at 17:44
6
Package: ResolutionX
Version: 1.0-0
Section: base
Priority: optional
Architecture: all
Build-Depends: debhelper (>= 9)
Maintainer: First_name Last_name 
Description: ResolutionX
    A simple tool to enable you to have your desired resolution without requiring graphics drivers.

This paragraph is a mish-mash of fields for source and binary packages. The first paragraph should describe the source package. Here, that would mean the first line has Source: instead of Package:. You can only specify Build-Depends for source packages, and Architecture for binary packages. The Version is derived from debian/changelog, and is not specified in debian/control.

I don't know how the rest of debian/control looks like, but just from this, I think you should split up the first paragraph:

Source: resolutionx
Version: 1.0-0
Section: base
Priority: optional
Build-Depends: debhelper (>= 9)
Maintainer: First_name Last_name 

Package: resolutionx
Section: base
Priority: optional
Architecture: all
Description: ResolutionX
 A simple tool to enable you to have your desired resolution   

Also note that packages are not supposed to have capital letters in their name. Indeed, packages to submitted to the Debian or Ubuntu repositories cannot have capital letters in their names.

| improve this answer | |
  • 4
    Also, the Maintainer field should be formatted as First Last <email@address.com> – saiarcot895 Aug 11 '15 at 19:13
  • 1
    @TellMeWhy FYI the name remains in the revision history. If you want it completely redacted, flag for a mod. – muru Dec 13 '18 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.