8

I yesterday upgraded from Windows to Ubuntu 15.04 but I have problem with my wireless adapter Intel Corporation Wireless 7260 (rev 73). It randomly loses internet connection. Restarting adapter always helps. (same it did with Windows, except that sometimes restarting adapter didn't help).

Additionally, I have weaker connection then I had with Windows. Thank you!

  • Please, specify your hardware in the body of the question. Is this Zenbook or Lenovo? – Léo Léopold Hertz 준영 Aug 25 '16 at 6:51
12

You can try this option. Run in terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1"

and reboot.

If this does not help, some other options can be used.

It looks like this adapter does not work well in 802.11n mode. So disabling it improves connection.

There are some other options, that may be tuned.

power_save=0
bt_coex_active=0
swcrypto=1

You can also try to disable not all 802.11n, but partially. It can be selected by 11n_disable=2, 11n_disable=4 or 11n_disable=8 instead of 11n_disable=1.

You can apply them the same way as with 11n_disable=1. You can use any combination of these options, e.g.

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi power_save=0 swcrypto=1"

You can enable all of them and remove one by one to test which one does the trick.

Every new setting overwrites the previous one.

To completely remove the options, remove /etc/modprobe.d/iwlwifi-opt.conf by running

sudo rm /etc/modprobe.d/iwlwifi-opt.conf

Please do not forget to comment on which options worked for you.

Explanation of the options can be found by

 modinfo iwlwifi | grep parm
| improve this answer | |
  • This will disable 802.11n, right? – david8 Aug 11 '15 at 13:19
  • Yes, it will. But it is revertable. Try it first. – Pilot6 Aug 11 '15 at 13:21
  • Intresting, it looks, that signal is better! – david8 Aug 11 '15 at 13:31
  • Thank you! How is it possible? Is there any solution without disabling wifi N? – david8 Aug 11 '15 at 13:35
  • I updated the answer. You can try others. – Pilot6 Aug 11 '15 at 13:42
0

I changed the channel wifi from 100 to 36 and the wifi card start to run again, other clients wifi mac had no issues with 100 and 36

Lenovo t440p
K 3.19.0-42-generic
U 15.04 64-bit
Intel Corporation Wireless 7260 (rev 83)
Firmware 25.17.12.0
linux-firmware Version 1.143.7
lib/firmware/iwlwifi-7260-12.ucode

| improve this answer | |
0

With firmware iwlwifi-7260-ucode-25.17.12.0, On an HP Pavilion g4, 10 ft. away from the Wifi router:

Link Quality=47/70  Signal level=-63 dBm, 

while the same distance on a Raspberry Pi Zero W:

Link Quality=70/70  Signal level=-34 dBm

I would expect much better!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.