1

I'm running Ubuntu 12.04.5 with LibreOffice. I was able to write documents in Hebrew without problems and at some point Hebrew stopped working.

I have no idea what caused this problem, but now I can't type Hebrew at all in LibreOffice - cursor doesn't move and characters don't appear. If I open Hebrew document, all Hebrew characters are invisible. In other applications Hebrew works fine.

My LibreOffice version is 3.5.7.2. Any ideas?

  • 1
    Dima, I am not suggesting that you should update to LO 5.0.0.5 available in ppa:libreoffice/ppa, but can you tell us if you don't for any reason at all ? It is just that LO 3.5.x seems very far away by now. – Cbhihe Aug 12 '15 at 11:47
  • Could it be that somehow you are missing a font. I doubt that this may be it, but did you check your language support in the LO option settings ? – Cbhihe Aug 12 '15 at 11:50
  • I guess you have iBus configured to run with Hebrew and to be able to write from right to left. Did you register any change there ? – Cbhihe Aug 12 '15 at 11:56
  • I used Update Manager to keep my system up-to-date and didn't realize that there is new major release of LibreOffice. I installed latest LO and it solved the problem. Thanks a lot! – Dima L. Aug 12 '15 at 15:27
  • Glad I could help. I posted the answer in case you want to mark it as such. Out of curiosity, do you use iBus along with a western script terminal, such as En_US.utf-8 for Hebrew ? – Cbhihe Aug 12 '15 at 15:48
2

Update to LO 5.0.0.5, aka " LO fresh" using the following ppa:libreoffice/ppa instead of downloading the deb packages.

The above repo will allow a permanent updating as new versions come out (hence the name "LO fresh"), whereas installing from the .deb files would not, because they are purposefully built on an "older baseline for maximum compatibility".

In the terminal, do per usual:

$ sudo add-apt-repository -y ppa:libreoffice/ppa
$ sudo apt-get update
$ sudo apt-get install libreoffice

Your configuration files should be preserved but you will see that option settings under Menu | Tools > Options are expanded.

Enjoy !

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.