0

I have two Ubuntu 14.04 virtual servers. One has IPTables/UFW on and enabled. It also has Vesta Control Panel installed. The other server is running some gaming servers, it does not have iptables running.

The problem i'm facing is that i'm wanting my website to get the server status of one of my gaming servers (from server 2). Server 1 (the server that has IPTables running, and VestaCP) is blocking the incoming query traffic from the query it's running.

VestaCP has it's own firewall interface. I've added the port 27017 (the query port for the gmod server) in there for UDP and TCP on IP 0.0.0.0/0 So my understanding is that all UDP and TCP port traffic should be coming through for port 27017. When this didn't work, i installed UFW, and did allow 27017. I also did an "allow from" for the External IP of Server 2. So it should be accepting all traffic from that IP.

Unfortunately it's just not working. When i disable the firewall through Vesta or UFW the query runs fine, but not when it's running. I also tested UFW allowing all incoming traffic, and this allowed it to query. Putting incoming traffic back to the default (deny) it is not querying.

Ontop of this, i can't seem to find any UFW or IPTables logs. I've tried multiple methods to try and get logging working, but nothing is in the syslog or the kernal logs.

Any help would be appreciated!

1

Got the log files working. Turns out I was needing to do sport not dport. Works now :D

sudo iptables -A INPUT -p udp --sport 27017 -j ACCEPT

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.