I am running 8.04 desktop as a server and hosting my own web server, has anyone experienced any issues with upgrade from 8.04 to 10.04?

  • 3
    I'd suggest you re-word the question as "Has anyone experienced problems upgrading desktop from 8.04 LTS to 10.04 LTS?" The question right now is a bit vague and technically I could answer "No" and that would still be a valid answer.
    – mfisch
    Jul 29 '10 at 2:25
  • I understand but some of the answers below would sound different if I change the title now.
    – grokus
    Jul 29 '10 at 2:56

I have tested this myself on a VM. And as Andrew said, this was heavily tested before the release.


Yes, I upgraded a production system, and worked fine.


While I haven't, that is one thing that gets heavily tested in LTS releases prior to their release.


I upgraded a production system from 8.04 to 10.04. I had to switch from gdm to kdm because gdm would not find any users to log in (but one could log in through a VT.)

I've filed the bug in Launchpad but it was never even triaged, not even with a request for more info! At least it saved me from having to reinstall the box.

Otherwise no hiccups. I removed Flash and Nvidia binary blobs from the machine (user requested it) before upgrading and then reinstalled them from the packages later. The new nouveau drivers are slick (VTs actually work with nouveau.)


Done on a VM, using the desktop edition. Seen no issue.


I had some issues on Desktop Edition once, something about the packages I had installed made the upgrade process go a little funky, and it kinda screwed up my python (had to manually find and compile module dependencies, and then I ended up having to reinstall later anyway to rid myself of wubi, and everything went fine there). On a clean install, or a production server, that shouldn't be an issue.


I’m having problems with a new install of 10.04 on an old AMD machine with a small memory footprint. It runs fine but installing a new kernel causes GRUB2 and/or the Kernel to become unbootable, I just get dumped at the Grub command line prompt. No warnings no error message just……..

I can still manually boot the original kernel but nothing since.

Looking at the bug list there are lots of people having similar problems but little apparent activity to resolve the problem.

I am very sad as the very heavily updated 8.?? was working fine with no problems just a bit of a dirty disk.


I actually upgraded from 8.04 to 10.04 but not in the replacement sense. Instead, I did a fresh install of 10.4 in a dual-boot configuration. I did experience problems (see my other postings here) but I eventually solved all of them. The experience is amazing and very rewarding. Highly recommended.


I installed the desktop version of 10.04 as a triple-boot option on a system with both 8.04 and Vista. I ran into two issues, both of which surprised me as I am used to Ubuntu installations running absolutely smoothly. Firstly, GRUB2 identified my Windows recovery and Vista partitions incorrectly and wouldn't boot either. This was fixed by customizing the boot menu using the correct drive identifiers. The second problem was that after the first update the machine wouldn't boot at all with the error message "udevadm trigger is not permitted while udev is unconfigured". The latter issue was fixed using information posted on the web. All three operating systems now seem to be functioning flawlessly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.