I have searched quite a lot, but it seems that I am the only unfortunate.

Last night I chose to upgrade (via Internet install) to 11.10 from my 11.04, but after the upgrade, Ubuntu just doesn't boot.

I was expecting some glitches, but never expected a complete crash.

My only fault, I left it to upgrade over the night, unattended, and went to sleep. Not knowing what might have happened.

I am attaching a screenshot, which might help knowing what's going on. . (Since I couldn't use system's internal imaging system as no OS was booted, I shot it from my phone's camera. I hope it's clear enough to read. please let me know if you need more details.)

enter image description here

Is there any way out?


As per instructions, I went to tty2, and ran sudo apt-get update which showed following errors:

after update

I then ran sudo apt-get upgrade and saw it processing many files. after a while when it quit, I restarted the system, but its still stuck at 'checking battery state'

sudo apt-get update still shows these errors, but upgrade says the system is upgraded 0 files to remove, 0 to change

  • Is the network cable plugged in? Looks like it can't fetch things from the archive – Jorge Castro Oct 14 '11 at 12:20
  • Darn! This one was on a WiFi connection, so it wouldn't have picked the network connection (surprised, because at a point Windows 8 installer did) So I'll try the same on my home computer where I have a wired connection – Aman Alam Oct 14 '11 at 13:07
  • Depending on the wireless card it might need a wired connection, but that would be your best bet. – Jorge Castro Oct 14 '11 at 13:12
  • Yes, @JorgeCastro. You're right. I realized this very thing. My home computer did just fine with a wired connection and is now working perfectly! – Aman Alam Oct 18 '11 at 5:22

It looks like your computer has more or less finished booting, but there's no display.

Likely solution

Try hitting Ctl-Alt-F2 (or Ctl-Alt-Fn-F2 if your keyboard has media keys). Do you get a login prompt? If so, enter your username and password, plug in an ethernet cable if possible, then enter the following command:

sudo apt-get update && sudo apt-get upgrade

Chances are this command will fail, and recommend a command to fix broken packages. Try that command, and then reboot with

sudo shutdown -r now

Possible solution

Hold Shift after turning your computer on. You'll be presented a program called GRUB that lets you select and boot different, older OS kernels. Try a few; maybe one will work.

Another Possible Solution

sudo apt-get install lightdm-gtk-greeter

note: it took a while for the desktop to load once I got passed the login screen.

Last resort

Boot into a live environment (that is, use an Ubuntu LiveCD or LiveUSB) and open the file browser. Mount your hard drive ('File System' in the left pane), and backup all important files onto physicial media or the internet.

Then install for a fresh system.

[NOTE: I'd probably wait a while before moving on to The Last Resort. A grizzled UNIX graybeard may come along with a more palatable solution]

  • Haha.. I would call the 'Last Resort' as poorman's solution :P still, I'll try the commands you posted and will post back – Aman Alam Oct 14 '11 at 7:21
  • You can also fresh install 11.10 from LiveCD without formatting. Your /home will be preserved, and installed packages list too (system settings will be lost) – Extender Oct 14 '11 at 9:01
  • I spotted one system at my workplace having same problem, so I have tried this stuff on it. I feel @j-johan-edwards was right, update said that many packages had troubles downloading. I ran upgrade again, and now am waiting for it to finish the process its in – Aman Alam Oct 14 '11 at 9:26
  • I ran update first, it showed me the errors, that I've attached in the question. I then upgraded the system, after a while, It got done with upgrade, but it still gets stuck at 'checking battery state` – Aman Alam Oct 14 '11 at 9:41
  • Hey, I just tried update and it asked me to run sud dpkg --configure -a. I did so, and later, ran upgrade as Johan had suggested, and Voila! I am back into Ubuntu again, with the sexy login screen! Thanks so much man! :) – Aman Alam Oct 14 '11 at 17:59

I had the same problem, but after I did Ctrl-Alt-F2,

sudo apt-get remove nvidia-173

and rebooted, the system started up as intended. I'm not sure why this worked, and I'm not sure it worked because of removing the nvidia driver -- but I had seen someone else doing the same thing, and it was a very easy thing to try.

By the way: In all, Ubuntu is a fantastic piece of software, and I wouldn't dream of changing it for any another OS. But I'm very, very disappointed with the new versions of Unity and Gnome 3 (gnome-shell), and I really wish they'd be easier to customize. Two simple examples: I really don't want to waste screen estate on the top of my screen, with a menu-bar which is several inches from the program it's supposed to support, and I'd love to have a way to easily see which programs are running on my current desktop, without having to add another panel (this time in the bottom of the screen) -- but I've found no way to change the standard behaviour. I didn't have any of these problems before 'upgrading', and I think it's a pity there seems to be no easy way to revert to my old settings.

I wish this 'uncustomizability' of both Unity and Gnome 3 had been pointed out to me be before upgrading, and I've actually decided to install Kubuntu (inside of 'gubuntu'), just because of it.

  • I agree with both of the above. I also am having difficulties in adjusting with the new 'type to search' thing, its difficult to be comfortable with. the Unity 3d is also quite buggy. – Aman Alam Oct 17 '11 at 8:47

I had the same problem.

Did the upgrade from home over vnc over the weekend. Tried to vnc later and couldnt get back onto my box.

Today I went into work and found that the machine would not boot up. After a while trying to figure it out, thinking that maybe it was a grub problem, i Googled and still didnt find any great solutions.

I then booted up into a previous kernel and finally got to the command prompt. From there i ran

sudo apt-get dist-upgrade

where I ran into the error telling me to

sudo dpkg --configure -a

after this completed, i rebooted the machine, no GRUB came up, it just booted correctly into 11.10 Gnome Login Screen.

Everything seems to be working perfectly now..

Not the answer you're looking for? Browse other questions tagged or ask your own question.