2

I am trying to install ubuntu-restricted-extras on Ubuntu 14.04 LTS (so that I can play mp3 files). However, I get an error message (see below). Any suggestions? Thanks!

 ...$ sudo apt-get install ubuntu-restricted-extras
[sudo] password for ***: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  freepats gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad
  gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly
  gstreamer1.0-fluendo-mp3 gstreamer1.0-libav gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers
  gstreamer1.0-plugins-ugly liba52-0.7.4 libass4 libavcodec-extra libcdaudio1
  libchromaprint0 libdca0 libdirac-encoder0 libdirectfb-1.2-9 libdvdnav4
  libdvdread4 libenca0 libfaac0 libfaad2 libflite1 libfluidsynth1 libgme0
  libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-bad1.0-0 libkate1
  libmad0 libmimic0 libmjpegutils-2.1-0 libmms0 libmodplug1 libmpcdec6
  libmpeg2-4 libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libofa0 liboil0.3
  libopenal-data libopenal1 libsidplay1 libslv2-9 libsoundtouch0 libspandsp2
  libsrtp0 libts-0.0-0 libtwolame0 libwildmidi-config libwildmidi1 libzbar0
  libzvbi-common libzvbi0 oxideqt-codecs-extra tsconf ubuntu-restricted-addons
Suggested packages:
  frei0r-plugins libchromaprint-tools python-acoustid libdvdcss2
  libroar-compat2 sidplay-base xsidplay slv2-jack srtp-utils
The following packages will be REMOVED:
  oxideqt-codecs
The following NEW packages will be installed:
  freepats gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad
  gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly
  gstreamer1.0-fluendo-mp3 gstreamer1.0-libav gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers
  gstreamer1.0-plugins-ugly liba52-0.7.4 libass4 libavcodec-extra libcdaudio1
  libchromaprint0 libdca0 libdirac-encoder0 libdirectfb-1.2-9 libdvdnav4
  libdvdread4 libenca0 libfaac0 libfaad2 libflite1 libfluidsynth1 libgme0
  libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-bad1.0-0 libkate1
  libmad0 libmimic0 libmjpegutils-2.1-0 libmms0 libmodplug1 libmpcdec6
  libmpeg2-4 libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libofa0 liboil0.3
  libopenal-data libopenal1 libsidplay1 libslv2-9 libsoundtouch0 libspandsp2
  libsrtp0 libts-0.0-0 libtwolame0 libwildmidi-config libwildmidi1 libzbar0
  libzvbi-common libzvbi0 oxideqt-codecs-extra tsconf ubuntu-restricted-addons
  ubuntu-restricted-extras
0 upgraded, 60 newly installed, 1 to remove and 8 not upgraded.
Need to get 851 kB/50.2 MB of archives.
After this operation, 86.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err http://archive.ubuntu.com/ubuntu/ trusty-updates/main oxideqt-codecs-extra amd64 1.5.6-0ubuntu0.14.04.2
  404  Not Found
Err http://security.ubuntu.com/ubuntu/ trusty-security/main oxideqt-codecs-extra amd64 1.5.6-0ubuntu0.14.04.2
  404  Not Found
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/o/oxide-qt/oxideqt-codecs-extra_1.5.6-0ubuntu0.14.04.2_amd64.deb  404  Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

My configuration in "Software & Updates" is as follows: everything is checked under "Downloadable from the Internet" (including the last item "Software restricted by copyright or legal issues (multiverse)"), and I have "Download from: Main server".

1

Run

sudo apt-get update

and try again.

Your package lists are outdated.

This can be seen by the version of oxideqt-codecs-extra apt is trying to install. It is 1.5.6-0ubuntu0.14.04.2 and outdated.

apt-cache policy oxideqt-codecs-extra shows

oxideqt-codecs-extra:
  Installed: 1.8.4-0ubuntu0.14.04.2
  Candidate: 1.8.4-0ubuntu0.14.04.2
  Version table:
 *** 1.8.4-0ubuntu0.14.04.2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ trusty-security/main i386 Packages
        100 /var/lib/dpkg/status
     1.0.0~bzr501-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.