2

I'm trying to install libmysqlclient-dev with aptitude and it keeps saying it will remove these packages:

The following packages will be REMOVED:  
esound-common gstreamer1.0-pulseaudio gyp javascript-common libaudiofile1
libc-ares-dev libc-ares2 libcdaudio1 libesd0 libgcrypt11-dev libgnutls-dev
libgnutlsxx27 libgpg-error-dev libgssrpc4 libgstreamer-plugins-bad0.10-0 
libidn11-dev libjs-node-uuid libldap2-dev libp11-kit-dev librtmp-dev 
libslv2-9 libssl-doc libsvga1 libtasn1-6-dev libv8-3.14-dev libv8-3.14.5 
node-abbrev node-ansi node-archy node-async node-block-stream node-combined-
stream node-cookie-jar node-delayed-stream node-forever-agent node-form-data 
node-fstream node-fstream-ignore node-github-url-from-git node-glob node-
graceful-fs node-inherits node-ini node-json-stringify-safe node-lockfile 
node-lru-cache node-mime node-minimatch node-mkdirp node-mute-stream node-
node-uuid node-nopt node-normalize-package-data node-npmlog node-once node-
osenv node-qs node-read node-read-package-json node-request node-retry node-
rimraf node-semver node-sha node-sigmund node-slide node-tar node-tunnel-
agent node-which nodejs

Are these for some package that I'm missing? These don't sound like things that should be uninstalled.

Apt-get doesn't require uninstalling them, but it also won't fix a dependency for libmysqlclient-dev.

  • Use synaptic instead of apt-get, with that you can see which packages will be removed and why – Prashant Chikhalkar Aug 10 '15 at 13:55
  • which dependency problem? – A.B. Aug 10 '15 at 14:02
3

You can remove the packages, it's safe. And if you need NodeJS you can install the packages again with:

sudo apt-get install nodejs

The same for gstreamer1.0-pulseaudio and esound-common.

The autoremove leaves your configuration in-place just in case you need it again afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy