I have a HP Laptop with Windows 8.1 installed and there seems to be some problem with the hard disk, due to which Windows never boots up. It just hangs at start up. I'm trying to recover some important files in my hard disk. I booted up my laptop using an Ubuntu Image. I was initially unable to mount the NTFS partition in Ubuntu. I got some error stating the partition is not clean. I ran the command 'ntfsfix' and it seemed to resolve some problems. After this, I was able to mount it using the following commands

sudo mkdir /media/c

sudo mount -t ntfs-3g /dev/sda1 /media/c

Now the NTFS filesystem is mounted, but it shows only two directories - "recovery" and "System Volume Information". Any idea why the other files in my NTFS filesystem are not shown?

I read that there is a problem mounting NTFS filesystems when Windows Fast-Boot/Hybrid shutdown mode is enabled(which is the default in Windows 8). Is this causing all the directories not being displayed? Any idea how I can recover other files from my hard disk?

I tried the solutions listed in Unable to mount Windows (NTFS) filesystem due to hibernation, and I can mount the disk, but as mentioned above, it shows only 2 directories: "recovery" and "System Volume Information". How can I access the other files in the NTFS disk?

Any help would be much appreciated!

  • 1
    possible duplicate of Unable to mount Windows (NTFS) filesystem due to hibernation – Pilot6 Aug 10 '15 at 11:38
  • Thanks for your suggestion, but I've already tried the options in the link you've listed. My problem is that I'm seeing only 2 directories in the mounted disk. – user2869520 Aug 10 '15 at 11:58
  • I retracted the vote. Did you try to look into this disk in Windows? Are there any other partitions beside sda1? Maybe there are no other files there, or they are located in another partition. – Pilot6 Aug 10 '15 at 12:00
  • Thanks for the quick response @Pilot6. I'm unable to boot up Windows in my laptop. That is why I'm trying to boot it with Ubuntu and see if I can recover some critical files in the disk. There are no partitions other than sda1 when I run the command 'sudo fdisk -l'. – user2869520 Aug 10 '15 at 12:12
  • 1
    Then it looks like there is no more Windows on this disk. You can use testdisk to recover files. – Pilot6 Aug 10 '15 at 12:13

You've probably followed this answer and that's a dangerous thing to do.

Ubuntu can easily recover data from a crashed Windows provided you don't have any hardware or Windows file system (NTFS) errors.

To get rid of NTFS errors you need to have Windows check your drive with chkdsk /f before attempting recovery under Ubuntu.

The "best" thing you can do under the circumstances you now have is to:

  1. Stop working on the original disk
  2. Make a full sector-by-sector copy of your disk onto a new disk using ddrescue

    After you've booted from the Ubuntu Live CD (the newest stable version is recommended) type the following commands:

    sudo apt-get install gddrescue
    sudo ddrescue --binary-prefixes --cluster-size=64 --sparse --timeout=20s /dev/XdY /dev/AdB /media/ubuntu/ddrescue.log

    where XdY and AdB are the drive letters for the source and target drive. Ensure you don't copy the empty disk on the full disk. Examples are sda, sdb, hd0, hd1, ... Ubuntu doesn't work with Windows drive letters but with disks and partitions. If you're unsure, ask!

    If the copy doesn't give you the data you need, continue to the next step.

  3. Use testdisk on the copy to recover some files

    If you cannot recover enough, execute Step 2 again and continue to step 4.

  4. use photorec on the fresh copy to recover some more files.

That's it! You will not be able to recover everything but let's hope that 87.5% is enough.

| improve this answer | |

Sorry for the necropost. Actually, it looks like this user may have mounted the wrong partition because I get the same result when I mount the FIRST partition of a Windows drive, which is, in fact, the boot partition for Windows. In order to get to the C: Drive, you will have to type the following into your terminal emulator:

sudo mount -t ntfs-3g -o ro /dev/sda2 /media/c

The location of your C drive may vary. You might want to look for the largest partition of the drive by typing

sudo fdisk -l

Then, you can replace the "sda2" in the command above with the C drive partition and find the files you were looking for. Windows might not boot, but you will be able to access the files you intended to access earlier.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.