1

The range of wifi is very limited, less than 10 ft whereas the smart phones connected to the same router can operate at a distance of up 40 ft (apprx).

This is a new HP laptop, bought with DOS pre-installed and then installed Ubuntu 14.04 on it. The wifi hardware is 'rtl8723be'. Based on other answers on this site I have re-installed the driver but that has not made any difference to the distance at which I can operate. I can work continuously for hours within the distance range of 10 feet. (no 30 minute connection dropping as has been reported by some other users)

Please help me resolve the problem

0

I bought a new laptop a few weeks ago and had the same problem, then I found https://github.com/lwfinger/rtlwifi_new/issues/28 and change the antenna position as Ghost says.

Here is the picture he adds to guide you (the antenna was connected to the pin on the right side) now my wifi works correctly.

http://i65.tinypic.com/vql568.jpg

I know its late, but just in case anyone else has the same problem can try this solution.

0

There is a way to set the parameters in the driver that determine which antenna to use.

The parameter is ant_sel and I was able to solve the problem by setting the value of this parameter to 2.

Use the following command to get the list of parameters and permissible values:

sudo modinfo rtl8723be

The command to set the parameter:

sudo modprobe -r rtl8723be

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf"

sudo modprobe rtl8723be

Please reboot the system and then check your wifi connectivity.

I am getting good connectivity even at 30 feet,

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.