0

I recently "upgraded" from windows 7 on the Acer Aspire One 752 my wife bought a few years back. Given the state of that particular windows installation the machine is performing a lot better now that it is running Ubuntu MATE 15.04.

I do however have some problem with video playback. The system is unable to play mov-files recorded with our iphones. The CPU is nailed at 100% and VLC is able to produce something like 1 frame every 3 seconds.

My guess was that it was driver related, so after some googling I tried:

apt-get install i965-va-driver libvdpau-va-gl1 libva-glx1 libva-drm1 vainfo mpv

But playback is still as poor as it ever was.

Judging from the VLC settings I think hardware acceleration should be utilized, but it is probably still not.

VLC settings

I also tried adding:

GRUB_CMDLINE_LINUX="enable_mtrr_cleanup mtrr_spare_reg_nr=1"

to /etc/default/grub and running sudo update-grubto no avail.

I'm not entirely sure what graphics card is in the machine, but lspci | grep -i vga says:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

glxgears is producing ~62 FPS, which I think is OK, so acceleration does not seem completely broken.

Youtube plays back a little bit stuttery, but it is atleast watchable. A great bit better than the mov-file playback.

I've also tried playing the mov-files using mpv with poor results.

Playing the files on my macbook works flawlessly, so the media in itself should be OK.

What else can I do to get playback working?

EDIT per Gannets suggestions:

$ sudo apt-get install libva-intel-vaapi-driver vainfo
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'i965-va-driver' instead of 'libva-intel-vaapi-driver'
i965-va-driver is already the newest version.
vainfo is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ vainfo
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_37
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.37 (libva 1.5.0)
vainfo: Driver version: Intel i965 driver for Intel(R) GM45 Express Chipset - 1.5.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
$ mpv -vo vaapi -hwdec=vaapi ~/Desktop/file.mov 
Playing: /home/user/Desktop/file.mov
 (+) Video --vid=1 (*) (h264)
 (+) Audio --aid=1 --alang=und (*) (aac)
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_37
libva info: va_openDriver() returns 0
Trying to use hardware decoding.
AO: [pulse] 44100Hz mono 1ch float
[vaapi] Decoder profile 'VAProfileH264High' not available.
[libav/video] h264: decode_slice_header error
[vaapi] Decoder profile 'VAProfileH264High' not available.
[libav/video] h264: decode_slice_header error
[libav/video] h264: no frame!
Error while decoding frame!
Error using hardware decoding, falling back to software decoding.
VO: [vaapi] 1920x1080 yuv420p
AV: 00:00:00 / 00:03:22 (0%) A-V:  0.471 Dropped: 4


           *************************************************
           **** Audio/Video desynchronisation detected! ****
           *************************************************

This means either the audio or the video is played too slowly.
Possible reasons, problems, workarounds:
- Your system is simply too slow for this file.
     Transcode it to a lower bitrate file with e.g. mpv encoding support.
- Slow video output.
     Try a different --vo driver (--vo=help for a list). Make sure framedrop
     is not disabled, or experiment with different values for --framedrop.
- Playing from a slow network source.
     Download the file instead.
- Try to find out whether audio/video/subs are causing this by experimenting
  with --no-video, --no-audio, or --no-sub.
- If you switched audio or video tracks, try seeking to force synchronization.
If none of this helps you, file a bug report.

AV: 00:00:03 / 00:03:22 (1%) A-V:  5.831 Dropped: 42


Exiting... (Quit)

Works no better, but clearly states that hardware acceleration is failing.

1

If you wanna try/determine hardware acceleration for video playback you should install:

apt-get install libva-intel-vaapi-driver vainfo

Then run:

vainfo

You'll see supported acceleration modes. Then, IMHO, the best player to try is mpv:

mpv -vo vaapi -hwdec=vaapi some_video.mkv

In player output you'll se if acceleration is working by

Using hardware acceleration

line.

For youtube make sure it plays through HTML5 (instead of shitty flash) by turning it on on a youtube.com/html5 page.

Also try to turning on hardware acceleration for your browser. How to depends on which browser you're using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.