After setting up 11.10 today, I seem to be having problems with my dual monitor set up. It worked without issues in Mint but today after I switched to 11.10 only one monitor seems to function.

This seems a little odd to me. During setup both monitors functioned without issue, although they were mirroring each other both monitors but as soon as it booted into Unity my secondary monitor stopped working.

I checked under settings->display and the second monitor doesn't seem to even be detected. On the off chance it had something to do with drivers, I upgraded the proprietary drivers to the latest version with zero success. If anyone has any ideas, I'd love to hear them.

  • We need more hardware information to help you, can you look at this question and then edit your question adding the information? – Jorge Castro Oct 14 '11 at 13:02

This turned out to be an issue with the settings for the video card. I executed the configuration editor for the video card. In this case by executing

gksu nvidia-settings

I then had to enable the second monitor and restart xwindows and presto it worked.

  • Can you elaborate on how you enabled the second monitor? Both my monitors are pivoted (portrait mode) and I don't know if it's even possible to use them that way in Ubuntu. – Dennis Oct 16 '11 at 21:27
  • I would say it should be possible, there's really nothing that different about pivoted mode except that you get a different number of pixels for your x and y axis. So if you can get one monitor work in the pivoted mode, I'd say it's possible. That said I launched the settings menu and selected the second monitor and simply clicked enable. I then turned on Xinerama and everything worked as I wanted it to. After I rebooted of course. – Mark D Oct 18 '11 at 4:24

I had problems with dual monitors in 11.10, when I un-checked the mirror screens I would get this error message "required virtual size does not fit available size: ..." I tried numerous combinations of custom xorg.conf files and default vs. proprietary drivers (I have an ATI dual head card) nothing worked. Out of frustration I thought about reinstalling and older version of Ubuntu. That made me wonder if the problem was Unity or lightdm. I set my default display manager to gdm and the dual screen works!

The command is:

sudo dpkg-reconfigure gdm

gdm may not be installed, to install it:

sudo apt-get install gdm
  • OMG, THANK YOU SOO MUCH. I spent about 6 hours today surfing the internet for a fix for my problem. The problem was that settings in amdcccle were not being saved when I clicked on "Apply", it was as if the app crashes! I tried about 15 different ways to fix it and none of them worked. I almost gave up until I found this post and I was like "What the hell, lets give this a try!". Suddenly BOOOM, it WORKED!!! I even reconfigured ubuntu to reuse lightdm after that and it kept working. I would give this post a thousand up-vote if I can! – Maher4Ever Dec 20 '11 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.