0

Background: Windows 8.1 was installed in BIOS mode on a RAID 1. I removed RAID and went to AHCI so I have 2 individual drives. Removed all partitions on drive 1. Drive 0, Windows 8.1 boots OK. Installed Ubuntu from DVD in BIOS mode and installed, made /, /home & swap partitions, installed Ubuntu.

Problem: When I boot up the PC, it boots directly into Windows 8.1. Going into BIOS/UEFI menu I can select boot order of disk 0 (windows) or cd/dvd (no disk 1 option) though in a manual boot options I can select drive 1 (ubuntu). If I select drive 1, it boots Ubuntu and I see the Ubuntu boot menu where I can select to boot Ubuntu or Windows 8.1 as part of my boot options. Selecting Ubuntu boots into Ubuntu OK, selecting Windows boots into Windows OK.

Question: How to fix/configure this system so it will offer an OS Boot Option when I do a normal boot?

  • Did you set your bios to boot in secure mode? When I ran two drives, Ubuntu and Windows, I had to press the "F12" key to get the Bios boot menu. – Buck Aug 9 '15 at 11:49
1

I ended up installing EasyBCD on Windows and adding Ubuntu to the menu (in Linux > Grub2 I selected drive 1 linux root partition). Now it boots Windows and gives a menu to select Windows or Ubuntu and it works great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.