0

The characters is gnome-terminal seem to have a different spacing for each one and some letters overlap. I tried changing the font and ticking the 'use system width and font' but I still get the same problem. I also tried different terminals like tilda, terminator but the problem persists Thanks in advance

1

I think you need to use a monofont to avoid this issue. Some other fonts may work sometimes, however, all monofont characters occupy the same amount of space.

Any "monospace" font will work well.

en.wikipedia.org/wiki/Monospaced_font

Also, here is a list of monospaced fonts.

More monospaced fonts.

7-of-best-ubuntu-terminal-fixed-width

Thanks @daltonfury42, you can change this setting by selecting Edit > Profile Preferences.

Under the General tab, select Custom Font and click on the font name to change.

  • 1
    Yeah, and you can set it by going to Edit -> Profile Preferences – daltonfury42 Aug 9 '15 at 11:26
  • Thanks for that, but the problem still persists. I don't think it has something to do with the fonts. – Jayakrishna Menon Aug 9 '15 at 11:48
  • @JayakrishnaMenon I don't know then. I do know that when I use system width and fonts, the letters are all screwed up and they overlap each other. However, when I switch to a custom font such as monospace bold or courier, the problem goes away. – mchid Aug 9 '15 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.