4

I want to get rid of the little name icon in the upper right. It wasn't there until a few updates ago. I tried disabling avatar/new profile management stuff in chrome://flags, but that didn't work. The settings are saved on Disabled but the profile name doesn't go away. Any help?

Thanks in advance. I'm running Ubuntu 14.04, and my Chrome version is 44.0.2403.130.

  • I did, no dice. Been trying at this for like a week. – cosmoflop12 Aug 9 '15 at 6:09
4

For Chrome 44 and higher:

chrome://flags/#enable-new-profile-management no longer works, and probably won't be fixed in future too. But there is workaround:

If you want a temporary solutions (that works only for a 'session', you can start chrome from terminal with the --disable-new-avatar-menu flag as in:

google-chrome --disable-new-avatar-menu

If you want a permanent solution:

  1. Edit your Chrome .desktop and add the parameter --disable-new-avatar-menu. So:

    sudo nano /usr/share/applications/google-chrome.desktop
    

    and edit the Exec line as follows:

    Exec=/usr/bin/google-chrome-stable --disable-new-avatar-menu %U
    

    My .desktop file for chrome looks like this:

    [Desktop Entry]
    Version=1.0
    Name=Google Chrome
    GenericName=Web Browser
    Comment=Access the Internet
    Exec=/usr/bin/google-chrome-stable --disable-new-avatar-menu %U
    Terminal=false
    Icon=google-chrome
    Type=Application
    Categories=Network;WebBrowser;
    MimeType=text/html;text/xml;application/xhtml_xml;image/webp;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/$
    X-Ayatana-Desktop-Shortcuts=NewWindow;NewIncognito
    
    [NewWindow Shortcut Group]
    Name=New Window
    Exec=/usr/bin/google-chrome-stable
    TargetEnvironment=Unity
    
    [NewIncognito Shortcut Group]
    Name=New Incognito Window
    Exec=/usr/bin/google-chrome-stable --incognito
    TargetEnvironment=Unity
    
  2. Restart Chrome

    enter image description here

For Chrome 43 and lower:

  1. Copy/paste the following into the omnibox: chrome://flags/#enable-new-avatar-menu
  2. Set the value to "Disabled"
  3. Restart Chrome
  • The temporary fix worked, the long term one did not. I checked the document and the new line did save (I added it at the very end). I did use gedit instead of nano, but I don't believe that should change anything? Rebooted too. No dice. (When just using Chrome from the side launcher) – cosmoflop12 Aug 9 '15 at 7:17
  • It should not be added at the end. Add it as the 6th line. I've included my .desktop file, if it helps. Shouldn't matter which text editor you use (as long as you've the write permission to the file) – Ron Aug 9 '15 at 7:27
  • It actually wasn't the 6th line either, but I found it eventually. Works now. Thank you so much! This has actually been a great learning experience besides just solving the problem. Thanks again. – cosmoflop12 Aug 9 '15 at 16:10
  • I have one other unrelated question though, you seem like someone who knows stuff and I didn't get an answer last time I asked it. Every time I open Chrome, the window opens in a position slightly lower than the last each time. It's extremely annoying, and happens even though I have windows set to open center, and every other application opens center consistently. This happens with both Chrome and Chromium. Any idea what this is or how to fix it? If not that's fine. Sorry to waste your time further. – cosmoflop12 Aug 9 '15 at 16:11
0

I was trying to avoid this for as long as I could and now I gave up. There is one thing you can do. Click on the name button and select "Switch person" and then select "Browse as guest". In that way your chrome will not synchronize setting over all computers.

  • My favorites and frequently visited sites and passwords and whatnot are pretty important to me. I tried this but it's tough to work without them. – cosmoflop12 Aug 9 '15 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.