1

So I once had a nice setup going with dual boot linux and windows 8.1 in UEFI bootloader mode, but then I had to screw it up and try playing around. I've currently got windows 8.1 installed, with no linux at all. If I go into the BIOS settings, ubuntu is still listed under the UEFI boot priorities. For reference, I have a Dell Inspiron 15 7537 laptop. I've reinstalled win 8.1 in GPT UEFI mode, but now I can't install linux whatsoever. Advanced startup in win will absolutely not allow me to boot into a linux or windows USB (yes formatted for GPT UEFI). I've got no idea where to go from here. I can get the system setup again with MBR Legacy, but would really rather sort this problem out if anyone has faced this particular problem before. Please don't suggest that I VM or Wine whatever programs I need as that isn't a viable option.

  • Is there a separate setting in UEFI somewhere to allow USB boot? IF you update UEFI/BIOS to new version it resets to defaults. Not sure what else a Windows install may reset as some UEFI settings can now be made from an operating system. Some cannot. – oldfred Aug 9 '15 at 17:30
1

Normally you can get a boot manager menu by pressing Esc, Enter, or a function key as you start the computer. (Which keypress does this varies from one machine to another.) I've heard of cases where this functionality stops working for some reason, though -- it sounds to me like the cause is really a firmware bug. Updating the firmware or resetting it to the default settings may clear the problem, but such updates and resets may also be difficult if you can't get into the firmware setup utility. This page provides instructions on one workaround that involves telling Windows to reboot into the firmware setup utility.

If that doesn't work, one possibility is to install my rEFInd boot manager from within Windows. The trouble with this approach is that if your system has Secure Boot set up, you'll need to obtain and install a Shim or PreLoader binary, too, which greatly complicates the setup process. (See the rEFInd Secure Boot documentation for more on this subject.) If you can get rEFInd to start up, it should present you with a menu of boot options, including any bootable external media on your system. If you don't see such options, hit the Esc key; this triggers a re-scan, which often picks up devices that were missed on the initial scan.

  • Secure boot is disabled. It's how I originally got the dual boot setup. I can boot into bios just fine. It just won't boot from usb when uefi windows is installed. The only workaround is to put it back into legacy mode and reinstall with that. I might try your boot manager solution but it'll have to wait until next week as I need the laptop working for weekdays. – NathanielJPerkins Aug 9 '15 at 14:23
0

If I understand correctly you cannot get into boot options and select USB. Have you tried shift restart. Windows do a different type of restart when you hold shift key at selecting restart. It helped me to get into BIOS and boot menu.

http://windowssecrets.com/langalist-plus/with-windows-8-off-isnt-really-off/

  • Yeah I've done that, windows won't beet into a USB drive from anywhere. – NathanielJPerkins Aug 9 '15 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.