4

I use setxkbmap -option "caps:swapescape" to swap caps lock and escape.

When I use the remmina RDP client to connect to a Windows server computer, the keyboard mapping no longer works.

I have tried FreeRDP, same problem there.

1
+25

Yes, that's absolutely normal: if you try to set your local keyboard to let's say Russian and you connect to a Japanese server, you'll still be typing Japanese. Both servers need to be set to the same keyboard...

That's why at a company I used to work at, we changed the corporate policy that all servers world-wide had to have QWERTY-US-International as their default settings!

  • So are you trying to say that RDP dictates that keyboards always send raw scancodes over the wire rather than allowing the client to interpret them and emit virtual scancodes? – binki Nov 23 '15 at 21:57
  • What I'm saying is that I've had tons of problems in the past with keyboard layouts in a multitude of OSes and standardised on US QWERTY Hardware for all machines and haven't had any problems since. Using US - International in SW even allows me to write all Western-European languages, which is all I need. – Fabby Nov 23 '15 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.