I'm wondering how it's possible to remove the little mail indicator applet in the global menu. I've uninstalled all the programs that use it, like Thunderbird, Empathy, and Gwibber, since I don't use any of them, but the icon is still there.

Any ideas?


12 Answers 12


You can remove the message indicator by removing the indicator-messages Install indicator-messages package by clicking on that link and clicking uninstall. Or by executing the following command in a terminal:

sudo apt-get remove indicator-messages

Then log out and back in.

  • 2
    @When I did that, this icon disappeared. However, it caused some bugs to emerge - clock/calendar is dissappearing from time to time and sometimes programs menu bar integrated with top bar is not working properly. Any idea why?
    – Rafal
    Oct 25, 2013 at 10:20
  • 25
    No need to logout just run killall unity-panel-service
    – desgua
    Apr 28, 2014 at 12:27
  • 14
    Why uninstall a package used by multiple programs when you can just disable the Thunderbird addon?
    – Ian Dunn
    Apr 25, 2015 at 7:04
  • 4
    @IanDunn because many people, like the person who asked the original question, don't use any of the multiple programs that use indicator-messages. May 4, 2015 at 5:48
  • 4
    I have to agree with @IanDunn, the least intrusive method should be used. Naive users dont understand how heavy of an impact removing certain services might have, so simply disabling the icon, rather than removing the entire service, would be the better suggestion. You can then supplement your answer by suggesting the removal of the service/app.
    – Todd
    Dec 2, 2015 at 0:00

If Thunderbird Mail is installed and is the default mail application in system settings->Details: then start Thunderbird, go to menu->Tools->Add-ons->Extensions and disable Thunderbird extension "Messaging Menu and Unity Launcher integration". Quit Thunderbird. Logout and Login to Ubuntu.

This solved it on Ubuntu 14.04 and 16.04 LTS without the need to uninstall anything.

  • Thanks a lot. I was searching for that option earlier under preferences.
    – thuyein
    Mar 27, 2015 at 15:43
  • 1
    I can confirm this works as of 16.12.2015 on Ubuntu 14.04.3 LTS 64-bit.
    – Vesnog
    Dec 16, 2015 at 20:48
  • 1
    In my machine I had to go to menu->Tools->Add-ons->Extensions
    – morhook
    Jun 29, 2016 at 18:03
  • 1
    Works also on Ubuntu 16.04
    – rneves
    Nov 4, 2016 at 16:34
  • 3
    This should be the preferred solution. Apr 5, 2017 at 19:51

Remove the package indicator-messages from within the Ubuntu Software Center.

Then reboot, gone!

  • 2
    I couldn't find it in the Software Center, so I did a sudo apt-get remove indicator-messages, log out and log in. The icon is now gone. Oct 22, 2011 at 13:54
  • 1
    for more advanced package management install synaptic from USS.. Oct 22, 2011 at 20:29
  • 1
    You shouldn't need to reboot.
    – lfaraone
    Jul 7, 2013 at 21:41
  • 1
    No need to logout or reboot just run killall unity-panel-service
    – insign
    Nov 30, 2014 at 3:41

This instruction will not remove the sound icon on Ubuntu 12.04 (Precise)

The program can be uninstalled from your system by opening the program "terminal", and typing in

sudo apt-get remove indicator-messages -y

It will ask you for your password, and then it will remove the program from your system.


The messages indicator only appears when an application has registered to use it; by default, no applications are registered to use it, meaning that the messages indicator is hidden. However, some applications, such as Thunderbird, register with the indicator as soon as you open them and leave no apparent way to remove them.

My solution is to reset the list of applications registered with the indicator to the default (empty), then kill the indicator to refresh it.

Open a terminal and copy/paste the following:

dconf reset /com/canonical/indicator/messages/applications
killall indicator-messages-service
  • 2
    This worked for me. I uninstalled Thunderbird but the icon was still there. Followed the instructions and now it's gone and stays gone. Seems less dangerous than removing the indicator package completely.
    – Alan Plum
    Feb 3, 2017 at 15:27

On 12.04 (precise):

sudo apt-get remove -y indicator-messages
killall indicator-messages-service
killall unity-panel-service
  • Works good in 14.04 under gnome-fallback
    – user371211
    Jul 23, 2015 at 13:19
  • This also works on 16.04 LTS.
    – Alan Plum
    Feb 3, 2017 at 15:24

this works in the gnome shell for 11.04, not sure about Unity interface:

open synaptic + remove "indicator-messages" + log out and log back in

  • I really don't know how to "open synaptic".... May 25, 2011 at 17:57
  • @George: if you use Unity: open the Dash (click on the ubuntu symbol in the top left corner), start typing 'synaptic', and click on 'synaptic package manager'.
    – joris
    May 25, 2011 at 18:47
  • @joris: Is this permanent? I don't want to get rid of it if there is no way to get it back. May 25, 2011 at 21:17
  • 1
    @GeorgeBailey If you want it back you just install that package again (which would require the CD or another way to transfer the package's installation data to the machine since there's no internet).
    – htorque
    May 25, 2011 at 22:00

There is a word of caution for removing the e-mail icon. You will also loose the Sound Control icon as both are connected to each-other. By removing the "indicator applet" package you will no longer be able to access or control the sound settings by clicking on the panel icon.

  • 5
    That is why you remove indicator-messages and not indicator as a whole. Feb 18, 2013 at 10:11
  • Removed indicator-messages under 16.04 LTS and the sound (and everything else) is still there after reboot.
    – Alan Plum
    Feb 3, 2017 at 15:25
  • The answer by @Hitechcomputergeek works and does not remove the sound control icon.
    – jmng
    Jul 24, 2019 at 21:58

1) In a terminal:

sudo apt-get remove indicator-messages
sudo killall gnome-panel

This will remove the package, and then remove the icon without rebooting.


Run sudo apt-get remove indicator-messages and then either log out or run killall unity-panel-service for the changes to take effect.


So doing a removal of "indicator-messages" will result in removing more then you want like the sound indicator and others. for a list of what you might remove start dconf editor and look under /com/canonical/indicator/messages/applications to see what is there. Having made this mistake of removing indicator-messages" the best solution is to edit /com/canonical/indicator/messages/applications and only remove what you want. In my situation I only had to reset (Default:[])/com/canonical/indicator/messages/applications/thunderbird.destop that set this to blank. re:List of applications that are shown in the messaging menu, Applications corresponding to the desktop file ids in this list are shown in the messaging menu. SO I vote for "Hitechcomputergeek contribution number 5


On Ubuntu 10.10 or earlier versions click with right mouse button on the icon and click on Remove From Panel

On Ubuntu 11.04 (Unity) click with right mouse button on the icon and click on Keep In Launcher Removing icons on Ubuntu 11.04 Classic works the same as on Ubuntu 10.10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .