I upgraded my ubuntu from 11.04 to 11.10 via mounting the latest alternate CD image released on Oct. 13 as the final standard version and running the cdromupgrade prompt successfully, with full latest upgrades installed before ending the distribution upgrading process and rebooting. After reboot, the new lightdm showed up as expected, and I could choose the login shell from a menu containing "ubuntu", "ubuntu 2D", "recovery console", "kde workspace", "cairo-dock with effects", "cairo-dock without effects", etc. next to my name which corresponds to my username.

HOWEVER, for example, I chose "ubuntu" (as the default selection) and input the correct (if not correct, the lightdm would ask you to input again, but it did not do so, I have tried) password and entered. The screen splashed to the black screen of the background text interface of gdm for a very short interval and then returned back to the interface of lightdm without my user account logged in and appeared as if I have not done anything on the laptop. Neither could I log in as a guest user as the same black screen splashed and lightdm reappeared.

Before the upgrade, I could run gnome 2, kde, unity all quite well on the laptop, but the status quo is that no one from the menu prompt beside my name can log in to my account, including the "recovery console".

Actually I can switch to the ttys and log in my account with my username and passcode normally, as can run all commands in the tty (I am currently doing this). I can also act like a superuser via the "sudo" command and get a # prompt via the "sudo -i" command, with the correct password, no problem.

In the root prompt, I can run "service lightdm stop" and "startx" to a root unity UI successfully (that is the way how this passage comes out), but in the $ prompt, after running "service lightdm stop" and "startx", it simply appears "No protocol specified" endlessly and no GUI appears.

I found the package "gnome-shell" not fully installed and fixed it, but it did not help, simply resulting in a selection in the menu which cannot access my account as its companions.

I have made all the packages in my laptop up-to-date and no updates should be installed.

My device is ThinkPad X61, with all its functions running well on all previous ubuntu distributions since 10.04 LTS. I had upgraded my os from 10.04 LTS to 10.10 in the way I performed today without any unexpected results one year ago.

I suspect it is the newly integrated lightdm that set these obstacles, and I want to get this bug fixed, please help!


6 Answers 6


I was able to fix this myself by removing the file ~/.Xauthority. For the record, you can find startup logs for LightDM under /var/log/lightdm - from there I was able to see that LightDM was getting stuck on something in that file, so I renamed it and was able to successfully log in.

  • Filed a bug? Needs to be addressed.
    – Oxwivi
    Oct 22, 2011 at 9:04
  • Did not fixed in my case. using Ubuntu 12.04 64-bit.
    – user25165
    Jul 16, 2013 at 22:13

I tried most of the above suggestions but after googling this error message found in .xsession-errors

mkdtemp: private socket dir: Permission denied

found this answer that worked

sudo chmod 1777 /tmp


  • Belated thanks for this, saved my life. Changed perms on /tmp yesterday, couldn't login to laptop today. Saw this and went, ah Jun 18, 2012 at 15:09

I had the same problem occurring to me (Ubuntu 12.04 LTS). I think it was because I was trying out startx -command with sudo.

I found out that the ~/.Xauthority -file was being owned by root, so at the login screen I hit ctrl+alt+f2 and from there I changed the ownership back to me (sudo chown user:user .Xauthority) and was able to login again.

  • I had root and also as normal user. But did not fixed in my case.
    – user25165
    Jul 16, 2013 at 22:16
  • This worked for me.. :) Ubuntu 12.04 LTS.. I changed the permission as well: chmod 777 .Xauthority Jan 18, 2014 at 7:25

GDM is still here if you want, you can do a :

sudo dpkg-reconfigure lightdm

And the prompt will ask if you want to start with LightDM or GDM. So if you are stuck again with LightDM or if you don't like it you can always go back to GDM.

But the solution of George Edison should work.


None of the previous suggestions here worked for me, but this made a difference:

In /etc/X11/default-display-manager changed lightdm to /usr/sbin/lightdm

I take zero credit for this; merely found this online somewhere among fifty other possibilities after days of trial&error. 11.10 is up to date and trying proprietary ATI driver fglrxdrm 8.93.4


Same problem in Lubuntu 11.10 - No GUI login posible, but the problem was DISK SPACE, when I went to console and tried to run MC I got a warning about disk space, I deleted some files and now all is working ok.

  • I had a similar problem running a dedicated XBMC machine with Lubuntu 11.10. Turns out /var/log had somehow filled the disk. Dec 19, 2012 at 17:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .