1

I can't seem to get anything to work on Ubuntu. I've struggled with everything that goes into installing, update and maintain the operation system and software.

But I've manage to get it installed and rebooted once.

Now I want my NVIDIA drivers for GeForce GTX 970 but this has me confused:

lspci | grep VGA
VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)

Because the computer overview says my graphics is "Gallium 0.4 on llvmpip (LLVM 3.6, 256 bits)"

I've tried most of the ways to install NVidia drivers:

  • .run file from GeForce website
  • Software Sources -> Additional Drivers
  • add-apt-repository ppa:xorg-edgers/ppa

I update everything and reboot. I'm expecting everything to work.

I'm greeted with the loading screen, but it's black instead of purple and frozen. I can't exit this any other way than to shut down manually.

And I'v come to my last solution every time, reinstall Ubuntu from LiveCD/USB My .Xauthority is own by me. My sources.list is normal (I've messed up that one some times)

The nvidia driver should be v352 or v355 but both are not working.

I'm on a fresh installation of Ubuntu right now. I just restarted to install the Software Updates:

  • Vivid-security
  • Vivid-updates
  • Vivid-backports

I'd like a secure method to ensure I'm using my NVidia graphics card and I'd like to know where I can read the potential errors I might get.

Without any drivers:

lspci -k | grep -EA2 'VGA|3D' show:

VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
Subsystem: Gigabyte Technology Co., Ltd Device 3670
Kernel driver in use: nouveau

"About this computer -> Overview" still says Gallium 0.4 on llvmpipe.

With drivers (in rescue mode as I can't get past loading screen):

`lspci -k | grep -EA2 'VGA|3D'` show:

    VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
    Subsystem: Gigabyte Technology Co., Ltd Device 3670
    Kernel driver in use: nvidia
  • 1
    It looks like the driver is installed correctly. This must be a bug in this driver. – Pilot6 Aug 8 '15 at 15:21
  • I'm going to test some drivers and see if any of them works. – OskyEdz Snakehult Aug 8 '15 at 15:26
  • 1
    The only ones that are supposed to work are 352 and 355. – Pilot6 Aug 8 '15 at 15:27
  • When I add the apt-repository it tells me to make sure I use another method to remove it. But that wouldn't Change anything right? – OskyEdz Snakehult Aug 8 '15 at 22:07
  • This is just the ppa description – Pilot6 Aug 9 '15 at 6:53
1

The following configuration is working for me. Ubuntu 14.04 + Kernel 4.1 + nvidia-346 ( i7-6700K + Nvidia GTX 9700 + Dual UHD Monitors ).

The driver was installed via the edgers ppa in root shell ( select advanced on boot and reboot with networking enabled).

I have tried Kernel 4.2/4.3 but neither worked.

I have tried nvidia -33x, -35x and 340 with kernel 4.1. None of them works.

  • 1
    On a hunch I updated to kernel 4.3. I also added the new graphics-drivers ppa and then updated the nvidia drivers to 355 ( the latest available as of now). All seems well. The reason I wanted to update all this was because my second monitor was not waking up from sleep and needed to be restarted. Lets hope all these updates fix this problem :) – Prashant Saraswat Nov 6 '15 at 2:31
4

Let me tell you this. I have tried even more than you have, I have even visited Linux forums and requeted for support, searched entire internet, asked dozens of people in IT and I never got it work...Same thing. I have NVIDIA GeForce GTX 970 graphic card and it looks like our card can't seem to be able to communicate well with Linux system. I have tried installing various distributions of Linux like Centos, Scientific Linux, Ubuntu (latest versions) and I can't install them, all I get is a black screen so unfortunately there is no solution for that. The only thing we can do at the moment is to wait until they add support for latest NVIDIA GeForce graphic cards.

  • Exactly same issue here. So it looks like we cant even get native resolution on our $400 card. I didn't remember seeing anything on NVIDIAs box that said "Windows only" – sintaxi Dec 8 '15 at 3:52
  • Exactly, it should say "Windows only". Long live Linux...:/ – jedi Dec 9 '15 at 10:33
  • Update: sudo apt-get cache search nvidia-* The latest driver I see is nvidia-361 - NVIDIA binary driver - version 361.18. Check the latest drivers also on nvidia.com/Download/index.aspx?lang=en – jedi Mar 5 '17 at 18:17
1

Try setting the nomodeset kernel option after installing the driver.

A good tutorial for Ubunutu for that would be here.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.