1

A couple of months ago I started following tutorials about updating to the latest stable version of the Linux kernel for Ubuntu -which is currently 4.0.9. The updates where flawless and I noticed my system is working better and running a bit faster. Yet everytime I want to update my other software, I get old packages of the official 15.04 Ubuntu kernel.

I already followed this tutorial How to skip kernel update? and worked well in hidding some of the kernel update packages, but I still get linux-headers-generic and linux-tools-generic on my list of updates (when running apt-get dist-upgrade).

My /etc/apt/preferences looks like this:

Package: linux-generic linux-headers-generic linux-image-generic linux-restricted-modules-generic linux-tools-generic
Pin: version 4.0.9
Pin-Priority: 1001

Thanks in advance for your help!

  • Try sudo apt-mark hold linux-generic linux-headers-generic linux-image-generic linux-restricted-modules-generic linux-tools-generic – texasflood Aug 8 '15 at 8:29
0

First of all, 4.0.9 is NOT the latest stable kernel version for Ubuntu.

The latest stable version is 3.19 that is installed in 15.04 and is getting security and other updates.

Installing unsupported kernel versions is not recommended and is reasonable if there is no other way to use specific hardware.

But if you are sure that you want to use unsupported kernels, update them manually and stop getting stable kernel updates, then remove kernel meta packages by running

 sudo apt-get remove linux-image-generic linux-headers-generic linux-restricted-modules-generic linux-tools-generic

You can not pin versions of these packages at 4.0.9, because there are no such package versions in repositories.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.